Go Down

Topic: Issues burning with 0023 but not 1.0 (Read 584 times) previous topic - next topic

Bifrost

Hello.

I have a 1280 board, and trying to use it as a ISP programmer, to program a standalone 328P, it works nice with 1.0 and 1.01 but not with 0023 and lower.
With 1.0> I don't have to use a capacitor or resistor to disable auto reset, it resets and burning the 328P excellent, but no luck with 0023< even with capacitor or resistor on the 1280, or a resistor from reset to VCC on the 328P.

I only get some thing like "avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x1c" or
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I cant use 1.0> cause I get some code errors on verify and cant change the hole programming code I want to burn on the 328P

Any ideas how to move further?

kf2qd

I had good results with 0.222. Had a 120 Ohm resistor between +5 and reset. 1.0 wouldn't work over 9600 baud.

Bifrost

Thanks.

Changed baud rate in boards.txt and in programmers.txt, I did try only change one in a time, all set up with a 120 Ohm resistor, the 1280 dose not restart so its not resetting, but with no luck
I could burn boot loader in 0022, but noting else.
Only get this message (this is with 57600 baud rate) 

C:\Users\Jonas\Desktop\NyMapp\arduino-0022\hardware/tools/avr/bin/avrdude -CC:\Users\Jonas\Desktop\NyMapp\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM3 -b57600 -D -Uflash:w:C:\Users\Jonas\AppData\Local\Temp\build5809572262799843608.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "C:\Users\Jonas\Desktop\NyMapp\arduino-0022\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM3
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 57600
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x1c

avrdude done.  Thank you.

Any more ideas?

Bifrost

Or is it a way to get a 0023 code to work in 1.0 environment, the code I want to upload contains some home made libraries as well.

florinc

Quote
Or is it a way to get a 0023 code to work in 1.0 environment

Copy (overwrite) the folder "hardware/tools/avr" from 23 to 1.0.

Bifrost

That did not work, it won't compile.
I will provide the errors later.

florinc

Quote
it won't compile

I thought you wanted to burn the bootloader. There is nothing to compile if you want to do just that (provided that you already have the hex file for the bootloader).

Bifrost

#7
Jun 26, 2012, 08:47 pm Last Edit: Jun 26, 2012, 08:49 pm by Bifrost Reason: 1
I have burn the bootloader in 1.0 and I can upload codes in 1.xx no problems there, like the blink code.
But the code i want to upload is written in 22 or 23 and of course 1.xx wont accept that.
And the 1280 burned as a ISP programmer wont upload my code in 00.23 to my stand alone 328P
I only get upload errors, see post above.

Maybe it easier to by a UNO REV3 to burn the code in 00.23, if its works in the 00.23 environment?

florinc

Quote
But the code i want to upload is written in 22 or 23 and of course 1.xx wont accept that.

Change the code so it compiles in 1.0.

Go Up