Pages: 1 ... 4 5 [6]   Go Down
Author Topic: [RESOLU] Relais 5V pour signal servo (ex-Recopier l'état d'un PIN en temps réel)  (Read 8563 times)
0 Members and 1 Guest are viewing this topic.
Paris
Offline Offline
Sr. Member
****
Karma: 2
Posts: 368
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pour le prototype, mon regard s'arrête sérieusement sur ce relais (optoMOS) :
CLARE LCC120

D'après la DATASHEET il est "TTL/CMOS Compatible", c'est un DIP8, il y a beaucoup moins de cablage qu'avec un 7400.

Le composant de mes rêves existe, c'est l'ADG884, mais c'est un MSOP10 (trop petit pour mes soudures en paté)

Sev
Logged

EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

Paris
Offline Offline
Sr. Member
****
Karma: 2
Posts: 368
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Le proto fonctionne bien avec des Clare LC120 achetés sur la bay :

La vidéo ici :
http://youtu.be/s2J-Oia6zQA

Je remercie tout particulièrement al1fch, qui lui, a réellement continué de m'aider par MP quand le sujet a tourné au vinaigre.

La seule question qui reste est, puis-je sans risque connecter l'arduino sur la commande du relais sans résistance ?

UniseV
« Last Edit: August 18, 2012, 07:59:48 am by UniseV » Logged

EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

Offline Offline
Full Member
***
Karma: 3
Posts: 179
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

L'entree de ton "relais" est une led. Donc il FAUT mettre une resistance.
Logged

France
Offline Offline
God Member
*****
Karma: 4
Posts: 971
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour
Une résistance est plus que souhaitable pour maitriser la valeur du courant dans la led du LC120
180 Ohms devrait fixer le courant à 17 mA environ dans la led. (loi d'ohm avec 3V aux bornes de la résistance)
Sans résistance le courant dépasserait  très probablement la valeur limite indiquée pour une pin par Atmel. (40 mA pour le Mega328)

« Last Edit: August 19, 2012, 06:46:50 am by al1fch » Logged

Paris
Offline Offline
Sr. Member
****
Karma: 2
Posts: 368
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bha justement, je n'ai rien trouvé dans la DATASHEET qui me permette de trouver la bonne valeur de résistance...
Logged

EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

Bretagne
Offline Offline
Edison Member
*
Karma: 16
Posts: 1398
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bha justement, je n'ai rien trouvé dans la DATASHEET qui me permette de trouver la bonne valeur de résistance...
si si! page 2, "input caracteristics" : max : 50mA, courant de fonctionnement : 10mA et 1,4V. donc à 20mA, t'es peinard. R = (5-1.4)/0.02 = 180 ohms, 20 points pour al1fch!
Logged

Paris
Offline Offline
Sr. Member
****
Karma: 2
Posts: 368
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci à tous, j'ai ajouté les 2 résistances de 180 Ohm sur le proto et ça fonctionne, je n'ai donc pas cramé les LCC120  smiley-wink
Logged

EN: Libraries are my Gurus, they make me believe anything they want !
FR: Les librairies sont mes gourous, elles me font croire ce qu'elles veulent !

Pages: 1 ... 4 5 [6]   Go Up
Jump to: