Go Down

Topic: So frustrated with Arduino! (Read 5788 times) previous topic - next topic


I have two arduino mega 2560s. I think they are both bricked. The computer will not recognize either of them at all. They worked great up until they got bricked.

Bricked arduino 1:
The "ON" led goes on and stays on when you plug it in. the led for pin 13 also goes on and stays on. Even if you hit the reset button. It does not blink. I'm guessing that's a firmware issue. How do I solve?

Bricked arduino 2:
The "ON" led goes on and stays on when you plug it in. The led for pin 13 blinks twice and then goes off when you plug it in. Still not recognized by any computer. No matter what I do. Plus, sometimes the led goes on and stays on and if you press the reset button it goes off but comes right back on and stays on. I fix this issue by holding reset, unplug, plug, then it resets and goes off. But it is still not recognized by the computer.

Very frustrated. Kind of want to abandon arduino and find something better.


What were you doing with the boards before they were bricked?


Another thing I forgot to mention is that the programs are still on the arduinos. The programs still work and run perfectly fine!

I think they were both bricked somehow by a laptop. Two different ones both running windows 7.

So, the first one was running. I flashed the program after updating something small, worked great, went to flash it again, but this time it didn't recognize it. Same thing with the other one. After mulitiple flashes and updating to get the program just how I want it, I go the next day, plug it into my laptop, and it doesn't recognize it. Each mega was bricked by a different laptop, if the laptop was the actual cause of the bricking.


Generally I find that the user is the cause of the bricking...

If you don't know what you did to the Arduinos, what makes you think you will somehow do better with some other product. Considering the number of successful users I think it is rather arrogant of you to assume that you had nothing to do with your perceived problem. Instead of throwing a temper tantrum why don't you do some reasonable troubleshooting and determne what the problem is  - other than its the stupid Arduino.

Oh -- if the programs are still running okay on the arduinos then they aren't bricked. The are working.


Jun 27, 2012, 06:34 pm Last Edit: Jun 27, 2012, 06:36 pm by njdurkin Reason: 1
The reasoning behind the tantrum is because I have been searching on and off for weeks, trying different things, but I can't find anyone with the same problem as me. Hardly anyone has the problem where the computer doesn't recognize the arduino.

And I know exactly what I did I just don't know what happened. I uploaded a program, tested it for a day, went to upload an updated program, and it wouldn't recognize it. That's literally what happened. I don't know why it didn't recognize it and I don't know why I'm seeing two different results with the lights and such.

If they aren't bricked, then why would they not be able to connect to a PC? I also read that if the led doesn't blink, it is bricked. That is why I thought at least one was bricked. But now that you mention it, if the program still runs, then that is not bricked! Ha!


Long on rant, short on detail.
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.
I speak for myself, not Arduino.


A good, basic start would be to post the code that you uploaded to the boards.


Post the code you used. If you modified any libraries, do mention which ones. Include any external components/wiring setup you had hooked up during the final hours of your Arduino. I've had this problem once where my last uploaded sketch ran, but I could not program the board due to the PC not recognizing it. It seemed my bootloader was corrupted, and I could not re-flash it either.

What kind of USB cable were you using? Were you powering the board up externally while plugging it into a PC via USB?

From a troubleshooting perspective, you are lucky; you have 2 occurances of which you can make logical comparisons between, to draw out possible causes to the brick'ing.


Jun 27, 2012, 10:28 pm Last Edit: Jun 27, 2012, 10:31 pm by njdurkin Reason: 1
I used two different programs. One was for a school project and it was really simple. All it did was constantly read a pin. If it was high is would output a high to a different pin. If it was low it would output a low. All it was doing was switching on and off a light. It was connected to a transistor. The input was just a switch, low true.

The code for the second one is attached.

I think I was using the same long gray cable during both incidents.
One time the board was powered externally while it was being tested.

The second one was always disconnected from power before anything was uploaded but it has been connected to the pc while being connected to power.

I didn't know this could cause a problem but I see that this may be my issue. Problem is. What damage did this do. And how can I fix it?


Jun 27, 2012, 11:27 pm Last Edit: Jun 27, 2012, 11:31 pm by JoeN Reason: 1
You can reprogram an Arduino with another Arduino:


Also, check this out:

Using the Arduino's ICSP: Workaround for a Fried ATmel8U2 (this is the USB chip)

As long as you didn't damage the micro-controller (you obviously didn't), you still might be able to use your Arduino board. This post assumes that you have the same problem that I do, a busted USB chip.

I will never ask you to do anything that I wouldn't do myself.


Also worth a look.
Go into Windows 7 Device manager and see if there are any problems in there (you will need to plug in the arduino's first!
Sorry for the noobish post but my knowledge is 10 years out of date!


I have been in the device manager. With the arduinos plugged in. It does not recognize them. Even if I do a refresh.

I purchased a USB AVR Programmer. Going to try the workaround when I get it.

Thanks for all the help guys.


Jul 06, 2012, 06:15 am Last Edit: Jul 06, 2012, 06:31 am by njdurkin Reason: 1
Okay finally got the programmer in the mal (Pololu USB AVR Programmer to be exact) and I get to the point where AVR studio 4 doesn't work. It won't let me install it. Says something about my operating system being the wrong one or something. So I downloaded 5. and 6. Both give me the same problem. When I pull up the programmer window it lets me select my COM port but when I go to select the device, atmega2560 is not an option! It's on option in the simulator but not when I have the com port selected. When I do a device id check it gives me an error saying that my device is a mega2560 and that I need to check what device I chose (this is when i have a random choice picked). There is no option!

Update: Found a 4.19 version that seems to be installing. Will update.


It won't let me install it. Says something about my operating system being the wrong one or something. So I downloaded 5. and 6. Both give me the same problem.

Sounds like you have bigger problems than the Arduino, to be frank. And as for "or something" ... maybe the actual message? Try taking a screenshot.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics


I would use avrstudio 4 but it won't work.

and i can't figure out how to get avrstudio 5 or 6 to do avrisp

any help?

Go Up