Go Down

Topic: Electrónica CNC/impresora 3D (driver, shields y placa) (Read 33 times) previous topic - next topic

fm

#105
Oct 07, 2012, 02:02 am Last Edit: Oct 07, 2012, 06:34 pm by fm Reason: 1
Lo que estoy haciendo es mandarle Gcodes directamente al puerto serie. En el LCD sale correctamente todo, mañana enchufaré la electrónica a la CNC a ver que hace. Pero vamos, creo que va a funcionar tal y como indica el MMI en el LCD.

@baronrojo - perdona, se me ha pasado tu post. El cubo tiene 3 entradas, las he conectado a pines analógicos. Por lo tanto no habría problemas a la hora de conectar finales de carrera. El código está, más o menos, preparado para soportarlo. Simplemente ahora lo tengo des habilidado.

El programa no puede saber cuanto le queda por completar el programa ya que el PC le envía 1 comando gcode a la vez. Hasta que no ha ejecutado el que tiene en curso el PC no le manda el siguiente.

Con respecto a introducir el 4 control del motor paso a paso, no es muy complicado incluirlo el el código actual. El único inconveniente es ponerlo en la electrónica actual. Simplemente no cabe. Date cuenta que es un PCB de 5x5cm!
   

grafisoft

Ya me diras si te funciona con la electronica conectada, sino grabo un video para los dudosas :smiley-sweat:

fm

Probado sobre la máquina y funciona a la perfección.

Le estoy mandando al software de mi controladoras desde Txapuzas Tx el siguiente código g: F3000 X10.01 y similares. Esto se lo estoy enviando desde la linea de comandas que tiene Txapuzas Tx. También lo he probado directamente abriendo un terminal serie contra la placa y perfecto.
   

grafisoft

Pues se me escapa porque no me funciona a mi esa forma :smiley-red: Porque algo manda, quiere como hacer algn movimiento la electronica, y nada, pasa al siguiente comando.

Y claro, el codigo que genera el coppercam, es todo asi, pues funciona mal.

Esta noche reviso todo de nuevo

grafisoft

Pues yo sigo en mis 13, a mi no me funciona el comando poniendo, de echo, no funciona nada pfffffffffff.

Go Up