Go Down

Topic: [RESOLU]probleme d'allimentation ATX (Read 1 time) previous topic - next topic

vassi974

Jul 06, 2012, 07:49 pm Last Edit: Jul 07, 2012, 07:35 am by Jean-François Reason: 1
Bonjour,
je viens de recevoir plusieurs servos a "gros" torq.
http://www.miniplanes.fr/servos/tower-pro/mg-995-servo-numerique-pignons-metaux-13kgcm-tower-pro-p-3967.html
et
http://www.springrc.cn/english/product.asp?id=123

13kg de torq et 30kg pour l'autre.
j'ai donc branché la pin de commande sur une pin digitale de l'arduino et les deux fil d'alim servo a une alim atx en 12v.
le problème est que au bout de quelques secondes l'alim atx s'éteint, comme si les servo consommaient trop.
Je ne vois pas sur les liens constructeur de précision sur l'amperage, mais quand meme c'est une alim 480watts...
Quelqu'un a t'il une idée de la bêtise que j'ai fait pour que sa ne fonctionne pas ?
merci a vous
je précise que j'utilise le sketch de demo de la librairie servo et qu'avec des servo standard je n'ai pas de problèmes.
Merci !!!!!

skywodd

Bonjour,


j'ai donc branché la pin de commande sur une pin digitale de l'arduino et les deux fil d'alim servo a une alim atx en 12v.
le problème est que au bout de quelques secondes l'alim atx s'éteint, comme si les servo consommaient trop.

Les servomoteurs tournent en +6v MAXIMUM, si tu leurs as envoyé du 12v ils risques de pas avoir apprécié et de s'être mis en court circuit ...
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

barbudor

Ca peut aussi être le cas contraire.
Certaines alims ATX ne démarrent même pas si elles n'ont pas une charge suffisante sur le +5V.
D'autres s'arrêtent au bout de quelques secondes.
Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

vassi974

#3
Jul 06, 2012, 08:02 pm Last Edit: Jul 06, 2012, 08:06 pm by vassi974 Reason: 1
oui, j'ai cru lire une fois que si on "charge" pas un peu l'alim, elle detecte qu'elle tourne a vide et s'éteint.
Je vais peut etre m'orienter vers cette direction, afin de créer une charge "leur" sur le 5v.
Les servo que j'utilise fonctionne normalement en 7v.
Tension qui n'existe pas en atx. Sur quelle connecteur vous brancheriez vous a ma place ?
merci


edit:

en branchant entre le rouge et le jaune on obtient 7volts, mais est-ce bien raisonnable comme bidouille ?
Merci !!!!!

skywodd


Les servo que j'utilise fonctionne normalement en 7v.
Tension qui n'existe pas en atx. Sur quelle connecteur vous brancheriez vous a ma place ?

Toujours prendre en dessous, jamais au dessus !
-> +5v le servomoteur aura un peu moins de couple mais il fonctionnera quand même.
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

vassi974

entre le jaune (+12v) et le rouge (+5v) on obtient 7v , mais je me demande s'il n'y a pas un risque pour l'alim ?
Merci !!!!!

barbudor

Pas une bonne idée.
Le retour courant ne se fera pas comme il faut.
Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

vassi974

effectivement, avec le 5v sa fonctionne correctement.
Au passage ma bétise m'a couté un servo, le CI à l'interieur a cramé. Il a donc été converti en motoréducteur DC à 360°... :~
il aura donc besoin d'un pont en H pour fonctionner a present, a moins qu'il y ai moyen de trouver la partie du CI qui a cramé (ce dont je doute) car je n'arrive meme pas a voir ce qu'il y a écrit dessus tellement c'est petit, faudrait que j'essaie avec un compte fil ou un microscope lol.
merci pour les info, j'edite le titre en "résolu".

Merci !!!!!

vassi974

je ne trouve pas ou on edit le titre du topic pour y ajouter "résolu" donc si un Modo passe par là.... merci :)
Merci !!!!!

skywodd


il aura donc besoin d'un pont en H pour fonctionner a present, a moins qu'il y ai moyen de trouver la partie du CI qui a cramé (ce dont je doute) car je n'arrive meme pas a voir ce qu'il y a écrit dessus tellement c'est petit, faudrait que j'essaie avec un compte fil ou un microscope lol.

C'est un amplificateur opérationnel en boitier CMS en général.

Sinon tu as le projet "open servo" :
http://www.sparkfun.com/products/9014
http://www.lextronic.fr/P5720-platine-open-servo.html

Mais je ne sait pas si il est compatible avec les servomoteurs de forte puissance.
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

fdufnews


je ne trouve pas ou on edit le titre du topic pour y ajouter "résolu" donc si un Modo passe par là.... merci :)


Il faut éditer le titre dans le premier post

piflechien54

Salut  :)
juste pour info concernant ton ATX, moi même je me sers d'une alim de pc pour mes bidouillages,  XD
et j'ai eu le même problème que toi, pour qu'elle démarre, j'ai dû brancher un girophare de voiture (12V, 21W)... :smiley-sad-blue:

toutes mes condoléances pour ton servo  ;)

avec 30kg/cm tu vas faire quoi ? (je sais j'suis curieux  :P )

@plus
Proverbe Tibétain : Un mensonge est un saut du haut du toit

anthology

une charge doit être appliqué sur une alim de pc pour quel reste en route
perso quand je fais des modifs dessus je met une ou deux résistances 5w 22ohm sur le 5V et plus de soucis
elle tourne depuis maintenant plus d'un an avec une imprimante 3D au cul

vassi974

Salut Anthology,
En fait, j'ai découvert Arduino il y a peu, l'électronique et la programmation on toujours manqué à mes bricolages.
Des projets y faisant appel, j'en ai des tonnes.
Pour le moment je "tatonne"... :smiley-roll-sweat:
mais ce qui m'interesse en general c'est de motoriser une multitude de choses et généralement avec des forces consequentes.
En ce moment je recupere tous les moteurs de monte vitres et d'essuie glaces de mes potes garagistes.
alors, pour répondre a ta question mon projet actuelle est une tourelle (style tank) gardienne de la maison.
elle sera mororizé sur 2 axes classique, camera IR, projecteur IR, pointeur laser, micro et Hp avec brouillage de voix, et eventuellement un tout petit petit petit petit paintball > j'ai pas lu la charte mais j'imagine que c'est politiquement incorrect donc un pistolet Nerf à fléchettes en mousse  XD
Tous cela dans une carrosserie en fibre de verre je pense (à definir).
Pour les autres projets, je pense coupler mon arduino a une alarme X10 qui traine dans les placard et y ajouter des barriere laser faites maison. Faut que je me documente sur le protocole X10. Il y a beaucoup de truc sympa a faire en domotique, tien d'ailleurs il faut aussi que je me fasse un distributeur d'air chaud pour la cheminé, qui ouvrira un clapet de répartition a partir d'une certaine temperature et fera tourner les ventilateurs ds le conduit à la demande... J'aimerais aussi réaliser une serrure RFID, m'essayer au pneumatique, me fabriquer un chronographe pour le tir sportif, un "hacking" de thermostat infrarouge pour mon four de fonderie etc... je ne parle pas d'une fraiseuse numérique c'est encore un autre univers et je n'aurais pas assez d'une vie pour tout faire.

Merci !!!!!

vassi974



il aura donc besoin d'un pont en H pour fonctionner a present, a moins qu'il y ai moyen de trouver la partie du CI qui a cramé (ce dont je doute) car je n'arrive meme pas a voir ce qu'il y a écrit dessus tellement c'est petit, faudrait que j'essaie avec un compte fil ou un microscope lol.

C'est un amplificateur opérationnel en boitier CMS en général.

Sinon tu as le projet "open servo" :
http://www.sparkfun.com/products/9014
http://www.lextronic.fr/P5720-platine-open-servo.html

Mais je ne sait pas si il est compatible avec les servomoteurs de forte puissance.



Merci pour ce lien , je ne connaissais pas ,et cela m'intéresse mais effectivement il est  precisé nulle part (ou alors j'ai pas trouvé) l'ampérage et la tension admissible, ce qui ne m'avance pas vraiment, donc si quelqu'un a des liens ou un retour d'experience a ce sujet je pense ne pas être le seul interessé ?!
Merci !!!!!

Go Up