Pages: 1 2 3 [4] 5   Go Down
Author Topic: Sudden unreliability with my network-enabled Arduino project  (Read 7792 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@wolfgang:
I followed your advice on using another capacitor - I bought one of these 1.0µF capacitors from digikey, and soldered it in near my other 2 caps and voltage regulator:

Back side, soldered in, before clipping leads:



And front:


(So I'm not sure if this is the right place to have put the new capacitor, but that's where it is)



When done, I put my device back in the garage, and hooked everything up and plugged it into the power outlet in the garage that I originally had it in, and so far no problems. But it's also colder now (still don't know if the weather matters), and it's only been about a week or week and a half at most, so I don't know if my problem has been resolved or not, but I sure hope so! I will definitely keep you all updated.



@Build_it_Bob:
Thank you for the suggestions...I think someone else suggested I do the same, but haven't yet as it doesn't seem like it would cause the problem I'm having (and on my board, the screws are nowhere near any electrical connections)...especially since my problem has been seeming to be a power problem. But I will definitely keep your suggestion in mind for future reference and implementation.

Thank you all so far.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Well after a few weeks of successfully running, I had the same problem again. smiley-sad It did seem to run longer than usual without messing up, but I did power cycle again, and let it run again, just to see if it was a fluke, and it happened again. Then again. So I don't know if it lasted longer because of the newly added cap and/or just because it's been colder, but that didn't fix it.

Trying to collect my thoughts and figure out what to do next...any more suggestions welcome. smiley
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 150
Posts: 6130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you considered isolating the power supplies and using opto-isolators on the interface to the proto board? You could drop the common ground, which could be causing your problem.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Whoa that was way over my head...could you maybe dumb that down a bit for me? smiley-wink
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 150
Posts: 6130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No problem!  smiley

Sometimes electric stuff is really noisy on the ground connection. That is where all this spike and sag stuff is being sent from those caps you just installed. You can power the Arduino with one wall wart, and the proto board with another wall wart. The grounds for each system can be separate.

Here is a datasheet for a standard optoisolator (optocoupler).
http://www.vishay.com/docs/81587/vom452t.pdf
Note the grounds are separate.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Actually my Arduino is my proto board...if you look at the top photo of my very first, original posting (on page 1) of this thread, you'll see that the proto board is basically my Arduino. The professional board to the right is just an Ethernet Shield which is receiving power from the 'Arduino/proto board'.
So with that, are you saying that I should power the Ethernet Shield separately somehow?
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 150
Posts: 6130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What is this doing? What are the red and black wires in the screw connectors? What do they do? What is the blue cube in the upper right corner? What does it do? It isn't a relay or anything inductive like that, right?
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My device (as I call it...which consists of the circuit on the proto board and the ethernet shield) allows me to open/close my garage door remotely via my Android phone.

The top pair (heavier gauge of red/black) of wires go to a reed/magnetic switch. (This and a magnet on the actual garage door, allow me to see the status of the garage door via my app - open/closed).

The bottom pair (lighter gauge of red/black) of wires run to my automatic garage door opener (specifically, they're connected to the same 2 terminals that the 'hard button' is connected to. You know, the button that you usually have near the door that leads from your house into your garage).

So the ethernet shield on the right obviously allows me to connect to the Arduino remotely (whether via my internal network or the internet), and open/close the door (and to check the status of the door).

The 'blue cube' in the upper right corner - it does happen to be a relay, yes. The relay is electrically connected to that 2nd blue screw connector where the thinner pair of red/black wires are leading out of. Which in turn, is connected to the automatic garage door opener that I just mentioned. So this does the actual opening/closing of the garage door.

I'm not 100% sure of where you're going here, but remember this strange thing:
It seems that I can have my device plugged into any power outlet in the garage and I'll have the same problem (eventually) (The reason I started this thread). However, as I mentioned in an earlier post, I learned that if I run an extension cord from the garage into a bedroom in my house and plug my device's power into that, I never seem to have the problem (at least after several weeks of testing).
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello all,

I have a possible interesting update on my project. On February 3rd, I put my device onto UPS power instead of just a cheap surge protector. It's an APC Back-UPS 650. And I haven't had one problem with my device since.

Maybe it's too soon as it's only been a month, but it sure is looking good so far...

(What does this suggest? What could I add as far as more active/passive components to my device so that it does not have to be on a UPS, if this is in fact solves my problem?)

Thanks. smiley
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 150
Posts: 6130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That suggests you need good power. I would have answered sooner, but I just now explained to the property manager of one of the condos I service that had a wireless fail this morning, that even a $300 router needs to be plugged in to work correctly.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So  there's nothing I can do/change on my device (i.e. add more caps or something) to make it more 'stable'? (Easy/cheap route?)

What kinds of things can I do to improve my home/garage power? (Difficult/dangerous/expensive route?)

Wait - so the router wasn't even plugged in? That's crazy!

(Thanks for the reply)
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 150
Posts: 6130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Skinware (humans) is unpredictable. The maid comes in to vacuum, and needs power. The plug available (controlled by a wall switch) was off, so the maid moved the router's cord to the switched plug so she could vacuum.  smiley-sad
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yikes!
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Still so far so good...it's been 8 weeks that I've had my device connected to a UPS and not a single problem.
(See my reply #53)
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 150
Posts: 6130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the info. It is good to hear that fixed it for you. That may help someone else.
Logged

Pages: 1 2 3 [4] 5   Go Up
Jump to: