Go Down

Topic: [Resolve]Arduino + Java crash (Read 1 time) previous topic - next topic

Badrocklo

Jul 13, 2012, 12:28 am Last Edit: Jul 13, 2012, 04:22 am by Badrocklo Reason: 1
Hello,

Please don't hit me if i don't speak very well i will do my best (french guy).

So first of all, i have install Fedora 17, it's run with KDE.
My fedora run un USB drive.
Arduino version is 1.0 from repository.
Java OpenJDK 1.7

When i go to the menu Tools/Serial Port arduino crash and it say :
Code: [Select]

WARNING:  RXTX Version mismatch
       Jar version = RXTX-2.2
       native lib Version = RXTX-2.2pre2
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fcf30fac2b5, pid=3131, tid=140527845656320
#
# JRE version: 7.0_03
# Java VM: OpenJDK 64-Bit Server VM (23.0-b21 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [liboxygen-gtk.so+0x1052b5]  Oxygen::StyleWrapper::type()+0x1c55
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid3131.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#


I have also a core dump but... that so underground for me.

So i don't know what i can do to use my arduino Seeeduino (based from Diecimila ATMega 168)

Thanks for reply.

The Clever Monkey


Hello,

Please don't hit me if i don't speak very well i will do my best (french guy).

So first of all, i have install Fedora 17, it's run with KDE.
My fedora run un USB drive.
Arduino version is 1.0 from repository.
Java OpenJDK 1.7

When i go to the menu Tools/Serial Port arduino crash and it say :
Code: [Select]

WARNING:  RXTX Version mismatch
        Jar version = RXTX-2.2
        native lib Version = RXTX-2.2pre2
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fcf30fac2b5, pid=3131, tid=140527845656320
#
# JRE version: 7.0_03
# Java VM: OpenJDK 64-Bit Server VM (23.0-b21 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [liboxygen-gtk.so+0x1052b5]  Oxygen::StyleWrapper::type()+0x1c55
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid3131.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#


I have also a core dump but... that so underground for me.

So i don't know what i can do to use my arduino Seeeduino (based from Diecimila ATMega 168)

Thanks for reply.


Can you attach or provide the hs_err_pid file it mentions in the crash log?

It's failing in a native library, outside of the VM. Have you tried updating the 64-bit liboxygen-gtk package on this machine?
I yield() for co-routines.

Badrocklo

#2
Jul 13, 2012, 03:24 am Last Edit: Jul 13, 2012, 03:34 am by Badrocklo Reason: 1
Thanks for reply,

My system is up to date, yum update say no update available.
(EDIT) I also try to reinstall oxygen-gtk package but no change.

And the file is attach.

The Clever Monkey


Thanks for reply,

My system is up to date, yum update say no update available.
(EDIT) I also try to reinstall oxygen-gtk package but no change.

And the file is attach.



Yup, this is a failure in a native library outside of the VM and outside of Arduino. This is a segfault in liboxygen-gtk.so, in a method called from the VM related to GTK painting when it is trying to bring up the UI.

I notice that you have the nvidia "CUDA" drivers on this box. This could be involved in some manner.

However, we might be able to side-step all of this and just run with a non-GTK LAF (Look And Feel -- the UI "skin" of the Java app).

Edit the "arduino" script and change the line that reads:

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base

to:

java -Dswing.defaultlaf=com.sun.java.swing.plaf.motif.MotifLookAndFeel processing.app.Base

See if that helps.
I yield() for co-routines.

Badrocklo

That work great,

I change on /usr/bin/arduino
the line (comment with #):
Code: [Select]

set_flags -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel


by this
Code: [Select]

set_flags -Dswing.defaultlaf=com.sun.java.swing.plaf.motif.MotifLookAndFeel

all work great thanks for help

The Clever Monkey


That work great,

I change on /usr/bin/arduino
the line (comment with #):
Code: [Select]

set_flags -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel


by this
Code: [Select]

set_flags -Dswing.defaultlaf=com.sun.java.swing.plaf.motif.MotifLookAndFeel

all work great thanks for help


Must be a difference between Arduino 1.0 and 1.0.1. My example was from 1.0.1.

Anyway, this proves that GTK, or a part of it, is not working right on this machine. Indeed, this is almost certainly the bug: https://bugs.kde.org/show_bug.cgi?id=261340

There is a solution in there that talks about "blacklisting" SWT.
I yield() for co-routines.

Badrocklo

Thanks,i try to solve with you'Re link but no change.
blacklist SWT in file don't do any change.
Anyways, my app don't crash at the begenning and now i have access to all menu, but i thinks my arduino board was down, im possible du load a program on it, but it's another problem so in another thread thansk.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy