Pages: [1]   Go Down
Author Topic: Embedded videos don't work unless Flash is installed/HTML5 Alternative?  (Read 977 times)
0 Members and 1 Guest are viewing this topic.
Spokane, WA, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Recently I have (intentionally) uninstalled Adobe Flash my from my system (Win7/Firefox) and have chosen to rely on HTML5 to view embedded videos. Most of the major video websites such as Youtube and Vimeo work fine without Flash installed, as they both support HTML5 video playback.

Here on the Arduino.cc forums, on my PC without Flash, embedded videos show up with a message saying that "A plugin is needed to view this content" (see attached screenshot). There is no way for me to view the video without installing Flash first, and no way of me knowing the URL of the video that is linked to.

Would it be possible to 1) See if Youtube has a newer way to link to videos that allows HTML5 video playback from within forum posts? Or, 2) Provide a text link to the embedded video so people without Flash could go to Youtube to view the video? This seems to be an issue with how embedded videos are linked within the forum software, not an issue with the actual videos on Youtube, Vimeo, etc. Thanks.

Matt


* Image1.png (28.84 KB, 970x590 - viewed 12 times.)
Logged

NSW Australia
Offline Offline
Faraday Member
**
Karma: 80
Posts: 3245
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Good point.

Apple is doing a good job in refusing to allow Flash into IOS.  If Google can clear it from YouTube entirely, that will be a significant step forward.  It will take a (long) while for the majority of websites to come to the party, but there is hope.  It really is mostly used for patently anti-social purposes (such as DRM).

There seem to be  number of problems with video embedding here.  (As well as a lot of other things   smiley-lol)
Logged

Pages: [1]   Go Up
Jump to: