Go Down

Topic: .pde files compared to .ino files (Read 4711 times) previous topic - next topic

lost_and_confused

I am getting a few examples with libraries and they have files with them.

They are "filename".pde

I can't for the life of me get the Arduino IDE to be the default program.

I can open them with editplus, but not the IDE.

What am I missing?

James C4S

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

lost_and_confused

Well, I right click and say OPEN - I don't see an OPEN WITH.

Select to pick my own progarm, browse, go to the Arduino IDE, select it and ......

Nothing happens.

It doesn't even load for that instance.

James C4S

You haven't said what operating system.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

lost_and_confused

Ooops.

the ubiquitous one.

Windoze  XP SP2.


James C4S

Sorry, I've never heard of "Windoze."  Wish I could help. 
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

lost_and_confused

Sorry that is my dispising of microslop and their OS.

It is otherwise called windows.

I call it windoze because it is/was so slow I used to doze while waiting for it to do things.


James C4S

If you dislike it and whoever microslop is, then why use it?  That seems silly.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

lost_and_confused

Believe me, if I could, I would.

Alas 90% of businesses these days use it.

So it is "the norm" and if you don't have skills with it, you are less-liked by the employer.


Anyway, that aside, I can't get these files to be opened with the IDE.

"Open with" - or "Open" and then pick a progarm doesn't yield the icon being changed and used in future times.


James C4S

This isn't by microslap, but it might apply to your computer.

http://support.microsoft.com/kb/307859
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

kf2qd

Which version of the Arduino IDE are you using?

Just right click and  open with Arduino.exe. When you save it the extension will change to .ino
.pde files are default for Processing.exe to avoid confusion between it and Arduino.exe

lost_and_confused


Which version of the Arduino IDE are you using?


1.0.1

The latest - I believe.

I got 1.0.0 or something and one day it told me there was a later version so I downloaded and installed it.


lost_and_confused


Just right click and  open with Arduino.exe. When you save it the extension will change to .ino
.pde files are default for Processing.exe to avoid confusion between it and Arduino.exe


That is what I tried.

Alas nothing happens.

Don't know why either.

So I can rename the .pde to .ino and they will work.   No worries then.

Renameing to .ino should do it
Makeing Arduino as default for .ino and processing default for .pde should
make them showup under open with as their is no install to either program

Go Up