Go Down

Topic: Parallel Programer not working on ATmega328P-PU [SOLVED] (Read 1 time) previous topic - next topic

RawthiL

Jul 19, 2012, 03:58 am Last Edit: Aug 02, 2012, 05:43 am by RawthiL Reason: 1
Hello, I'm having troubles with my ATmega328P-PU that I bought in sparkfun...

I have a parallel programmer that works fine (I burned bootloaders for ATmega8 and ATmega168), but when I try to burn my ATmega328P-PU it says "initialization failed, rc=-1", if I plug an ATmega8 It says "avrdude: Expected signature for ATMEGA328P ..." so the programmer can comunicate with my 8 and 168 but not with my 328P-PU.

Is there a way to know if this microcontroller is dead?, or is there any trick to burn an ATmega328P with a parallel programmer?

My setup is a little odd, but it is working fine:
Pentium MMX with DSL (Linux) and its lovely parallel port connected to a protoboard (Arduino bare-bones, power supply with caps, 16Mhz oscilator, 10K pull up in reset pin and 470/220 ohm programming resistors)


Thanks in advance!

Osgeld

default from factory is using the internal oscillator, remove the 16Mhz crystal, set fuses and replace (in my guess)

spcomputing

"default from factory is using the internal oscillator, remove the 16Mhz crystal, set fuses and replace (in my guess)"

...and you might need to apply a 1MHz external...


RawthiL

I tried removing the 16 Mhz oscilator and now it only says:
"avrdude: Expected signature for ATMEGA328P ..."

Does that mean that the u-controller is fine?

I dont know how to set the fuses (I mean the actual setting not the fuse config), I thought that it was Arduino who set the fuses before burning the bootloader

spcomputing



...and you might need to apply a 1MHz external...


why


I had a couple of ATMEGAs take a bootload and then stop talking (No SIG - 0x00000).  Looked around for a couple of weeks and I was ready to buildout a parallel programmer and found a reference to 1 MHz on the crystal pins.  Applied a 1MHz (1/2 pulsewidth) generated from an UNO to the breadboarded chip, and viola the serial programmer was just chatting away (slow clock on the programmer/USBASP).

Suspect that the 1 MHz factory default can not be cleared easily (at other frequencies) when doing the initial bootloading.  I have not tried the really slow baudrates, but 20 minutes was slow enough for me.  Also tried all the avrdude "B" parameters, no good.





RawthiL

I finally bought a 1 Mhz oscillator and it worked, I burnt the bootloader with it and now it works with the 16Mhz crystal of the Arduino.

Thanks!!

spcomputing

1MHz, the song to wake those sleepy baby Atmegas...

Have fun!

Go Up