Go Down

Topic: WTV020-SD-16P - Help & solution tree (Read 8810 times) previous topic - next topic

GaryY

I spent a several days ( 12-15 hrs ++)  trying to get a WTV020-SD-16P to work as a standalone sound player, just as a test for my project. 
It did finally work as a standalone. If I can do it, so can you, from this test setup, the experience can be built on.
I used a buck power supply ( cost less than $2 ) to get the 3.3 V from a 5v power supply ( the 5V power supply is a cell phone charger ). 


Some really good information is scattered in the forum, so I started a post here just for listing best practices and troubleshooting tips.

My big problem: Wired very simply as shown, MP3 mode, when the play was triggered by connecting pin 9 to ground, all that came out was a feeble 1/2 sec beep. It didnt matter if the SD card was blank or had files on it. 
Root problem was the micro-SD memory card. It worked fine connected to my PC thru a card reader.
The needed advice, not found in vendor documentation, is: " Before the memory card can be used it must first be formatted with FAT16 option."

After reformatting the memory card, copied sample .ad4 files to the card & voila ! success !  http://www.4dsystems.com.au/prod.php?id=73. 
I'd thought the files would be limited to 20 seconds, these sample ad4s seem to be alot longer than that.

I also wired pin 2 [DAC +] up to a 15W amp to drive a car speaker. There is a loud POP when the sound files starts and stops, not sure of a DC blocking capacitor will fix that.   Any suggestions ?

P.S. the LED goes out when pin 15 "BUSY" output goes high, so the LED really should be labeled "Not Busy".
After the aggravation of getting started is over, this inexpensive module looks to have alot of capability and uses for many fun hobby projects.

the-rebel-agent

Good to read experiences from other members here. You can read more of this sound module here:
http://arduino.cc/forum/index.php/topic,110924.msg859433.html#msg859433

GaryY

Thank you, the link takes to good solution areas. Having alot of good luck using the AD4 converter, IMHO, it is key to have successful sound tracks copied to the uSD card.

the-rebel-agent

I used both, usb recorder and ad4converter.exe. I am experiencing a problem with the playback. Somo files do play fine, some others stops at 5,10 or more seconds. I am sure my source code for serial control is right, as a matter of fact, I think it could be the uSD card reading problem. Any idea?

the-rebel-agent

File 0001.ad4 is 22Khz 4 bit and plays entirely. Created with ad4coverter.exe from SOMO website.

the-rebel-agent

This file 0018.ad4 is 32Khz 4bit and only plays for a few seconds. Would you mind to test them with your setup?

onesky

did u connect to analog or digital pins on arduino?
my board now is not ready, i will try on weekend

the-rebel-agent


the-rebel-agent

#8
Jul 25, 2012, 05:59 am Last Edit: Jul 25, 2012, 06:02 am by the-rebel-agent Reason: 1
Following with the idea of the thread, this is the only micro sd card working so far for me:



And these are the ones did not work. An original Kingston:



and a fake one:



Not completely sure Sandisk is totally working yet, since I am having that playback problem. Hope this helps.

synack

Hey man, just wanted to say thanks for all your great work here.. I originally saw this module a while back and was wondering if it would work for me and it seems to do quite well.  I was wondering if there is a way to loop clips?  Any ideas or solutions are welcomed.

Synack

the-rebel-agent

Yes you can. Check this video:

http://www.youtube.com/watch?v=_RGRAhex7Zs

Music and FXs sound using this module.

fungus

Hello...

I've just bought a couple of these, not knowing what problems were waiting for me. I've just been fighting with them for a couple of hours and basically had every problem described in these forums. I think the real problem comes down to power supply.

a) SD cards need up to 3.6V to operate - more than the Arduino 3.3V pin can supply.
b) SD cards need a surprising amount of current to work. Add to this that you're also trying to drive a 4W speaker (or whatever) and you'll soon overwhelm a little voltage regulator.

The voltage/current needed by a card obviously varies between cards which is why some cards work better than others. Using an external amplifier probably helps a lot, too.

In my case I was getting nothing at all with the Arduino 3.3V supply. I tried the "two diodes" trick and got sound, but the files only played for a couple of seconds before stopping. I looked at the voltage and it was going up and down wildly. There was usually a drop down to about 3V when the sounds stopped playing (probably low enough to give SD card errors...)

As a test, I tried using a 3xAAA battery pack, and ... bingo! Everything started working perfectly. The batteries were putting out about 3.8V and not drooping too much when things got busy.

Bottom line: I think you need a fairly beefy 3.6V supply to run this thing properly (or a reasonably good 3.6V supply plus an external amplifier).


No, I don't answer questions sent in private messages (but I do accept thank-you notes...)

fungus

I've done some more playing today and I'm convinced that ALL problems people are having with this module are down to the power supply.

It NEEDS 3.6V to work so plan on getting one of those adjustable step-down modules as shown at the start of the thread if you want it to work.

(Or run it off 3xAA/3xAAA batteries, I've had no problems at all using it with my battery pack)

No, I don't answer questions sent in private messages (but I do accept thank-you notes...)

elac

@ Fungus,
Just tried it at 3.6v and the module I thought was dead worked. Thanks for sharing the info, great find!!!
It's all about the skills

fungus


@ Fungus,
Just tried it at 3.6v and the module I thought was dead worked. Thanks for sharing the info, great find!!!


I played some more yesterday and confirmed it again. It's very clear that 3.3V isn't enough and that even 0.1V more can be the difference between it working/not. I'm currently trying to figure out a cheap/easy way to power them.

No, I don't answer questions sent in private messages (but I do accept thank-you notes...)

Go Up