Go Down

Topic: LCD03 I2C/Serial Display - comando per lampeggio (Read 918 times) previous topic - next topic

cyberhs

Incredibilmente questo ottimo display a cui si può connettere un tastierino 4x3 ha due difetti:
1) nella modalita seriale vuole 2 bit di stop;
2) non prevede la possibilità di lampeggio di una stringa e la modalità reverse.

Il primo problema si risolve con una impostazione dei registri della USART (uso un Arduino MEGA 2560 che prevede più seriali).

Per il secondo, invece, per quanto abbia provato varie configurazioni (ho provato a controllare anche eventuali comandi non documentati) non ho ottenuto alcun risultato.

Eppure, a seguito di una erronea trasmissione, ho visto una stringa lampeggiare, ma non sono riuscito a riprodurre il fenomeno.

Qualcuno conosce la soluzione?

Ettore Massimo Albani

PaoloP

I limiti non sono del Display ma del modulo di controllo.
L'unica cosa che mi viene in mente per il lampeggio e la possibilità alternare la scritta con degli spazi bianchi.

Michele Menniti

Concordo con Paolo, la trasmissione ed il refresh sono così veloci che il sistema non risentirà affatto di un ciclo in cui mandi alternativamente la riga con caratteri e la riga vuota. L'ho testato tempo fa sull'intero display (un normale collegamento a 4 bit) alternando i caratteri ed il clear, ovviamente il "lampeggio" avveniva sull'intero display.
Se è una cosa che ti serve, potresti aggiungerla alla libreria, in modo da attivarla con un comando a tuo piacimento.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

cyberhs

Sì, avevo già pensato alla stringa "alternata" e sono d'accordo sul fatto che il limite sia nel modulo convertitore.

Tuttavia, ripeto, sono riuscito ad avere (per caso) il lampeggio di una stringa, quindi sono convinto che il comando esista in qualche modo.

Ho inizialmente pensato ad una dimenticanza osservando che il comando 7 non esiste (vicino, guarda caso, ai tre comandi 4, 5 e 6 di controllo cursore), ma purtroppo non funziona. E naturalmente ho provato anche con gli altri comandi "saltati".

Mi rimane da provare tutta una serie di caratteri misteriosamente assenti (dal 136 al 161), poco prima dei caratteri katakana.

Continuo nelle mie ricerche.

Grazie, comunque.

Ettore Massimo Albani

Go Up