Go Down

Topic: Serial Port problems (Read 5 times) previous topic - next topic

com64

Dear spcomputing,

Thank you. All problems are not totally resolved but I can use the Board. The whole system is very capricious. Sometimes I have an instant communication through COM8, sometimes I have to reboot the computer. Sometimes I lose the connection when uploading a new sketch. Also when uploading a new or a modified sketch, I sometimes have the message saying: "COM 8  busy with another program. Try to uninstall the other program". Most of the times, holding the reset button while clicking on the 'Upload' icon and only then, releasing the reset button helps…but not every times.
Despite those minor nuisances, I like the board and can see its enormous potential for future uses when I shall finally correct those problems.
Next step is to build a Real Time Clock  and use the 'time' functions.

Regards

c64

eried


Dear spcomputing,

Thank you. All problems are not totally resolved but I can use the Board. The whole system is very capricious. Sometimes I have an instant communication through COM8, sometimes I have to reboot the computer. Sometimes I lose the connection when uploading a new sketch. Also when uploading a new or a modified sketch, I sometimes have the message saying: "COM 8  busy with another program. Try to uninstall the other program". Most of the times, holding the reset button while clicking on the 'Upload' icon and only then, releasing the reset button helps…but not every times.
Despite those minor nuisances, I like the board and can see its enormous potential for future uses when I shall finally correct those problems.
Next step is to build a Real Time Clock  and use the 'time' functions.

Regards

c64



Are you using 1.0.1 right?

I am experiencing troubles with the serial port also, never had issues with 0023 (besides some delays with bt devices) but now the menu is constantly grayed out... I tried updating the 8u2 to the rev0003, but after some  uploads I got the same  issue. Very annoying, the only workaround I found is to change the com port number every time this happens.

My website: http://ried.cl

spcomputing

Another silly idea is to put a 2.0 USB Hub.  Someone else had the same issue and moved from the front PC USB access ports to the back and fixed it.  Something is fighting in the MS USB Driver based on the motherboard hardware.  I had a machine that was fighting with the mouse on an old notebook and blam, all fighting gone.

Dexter7

I am having a similar problem with the serial port on my Arduino Uno, Rev 3, that is being discussed in this thread.  When I try to run a program on the Arduino, I get the error the error message: "Serial port "COM3' not found. Did you select the right one from the Tools > Serial Port menu?"
When I go to the Tools > Serial port menu, it is greyed out.  In reading the other posts to this thread, I noticed that, at one point, someone asked another member:  "Do you hear the beep sound when you plug in the Uno to the computer?"  My answer to that is: No, I do not get this sound.  When I look at the device manager, it shows the Uno as being an "unknown device."  Does this mean I should download the proper driver for the Uno?  Will this solve the problem?


Go Up