Go Down

Topic: ATmega328 with the Arduino Optiboot (Uno 16MHz) (Read 2 times) previous topic - next topic

xvjeko

Hello, i just purchased a DIP version of the chip ATmega328 with the Arduino Optiboot (Uno 16MHz) bought on ebay (more than 500 sold).
I connected it base on the given example http://arduino.cc/en/Main/Standalone
It runs the "blink" sketch, and the reset button is working properly... The problem comes when I try to upload to board...


I am trying to upload the "blink" sketch....
arduino output:
Code: [Select]
Binary sketch size: 1010 bytes (of a 32256 byte maximum)
D:\programs\arduino\arduino-0021\arduino-0021\hardware/tools/avr/bin/avrdude -CD:\programs\arduino\arduino-0021\arduino-0021\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM3 -b115200 -D -Uflash:w:C:\Users\xvjeko\AppData\Local\Temp\build441449957621406107.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

        System wide configuration file is "D:\programs\arduino\arduino-0021\arduino-0021\hardware/tools/avr/etc/avrdude.conf"

        Using Port            : \\.\COM3
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.



windows setup (selected arduino uno, and the apropriate COM3 port selected in the arduino IDE)


Thanks for any help !  :) (PS. right click on a picture and select view picture)

johnwasser

Did you press the reset button briefly when you saw the "Binary sketch size:" message?

If that doesn't work did you try swapping the RX and TX wires?
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

xvjeko


Did you press the reset button briefly when you saw the "Binary sketch size:" message?

If that doesn't work did you try swapping the RX and TX wires?


ty for the anwser, i will try pressing the reset button "briefly" when i'll see the "binary sketch size" tomorrow.
I tried swapping tx rx and nothing happend. And my UART is working properly.

CrossRoads

Don't press it briefly - press & hold it, then release it when you see "compiled xxx bytes of 32xxx", message similar to that.
May have to try a few times to get the right spot.
Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

CrossRoads

And post smaller pictures too - hard to scroll around something that large.
Resize to ~800 wide before posting.
Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Go Up