Go Down

Topic: Solution to PCREL error for avr25/ATTiny84/ATTiny85/ATTiny88. (Read 15599 times) previous topic - next topic

ARJunior

Thank you Tom !
My code is compiled perfectly on Attiny85 now !

Tom Carpenter

#31
Dec 27, 2013, 11:46 pm Last Edit: Jan 05, 2014, 09:02 am by Coding Badly Reason: 1

You're welcome :) Glad it works for you.
~Tom~

I have upgraded to latest version of Arduino IDE and again I was both glad and surprised.

Glad: for your solution - thanks Tom

Surprised: How it is possible, that the ld (linker) is not included in distribution already patched. Does anyone know why?

I know I'm resurrecting this post but I wanted to let the community know that I was having the same _PCREL_ error while trying to verify code on an ATTiny85 using IDE 1.0.6 on a late 2014 mac. I downloaded the zip in post #4 and moved it to the mentioned directory, after deleting the old ID file first, and it worked like a charm. thanks for the fix Tom.

Weird that the Arduino team still has not addressed this yet seeing as there are plenty of people using ATTiny85s and the fix seems so simple, must be super busy.

ƎR

I just updated IDE to 1.0.6 on windows and the problem came back... with 1.0.5 worked wonderfully.
Anyone have noticed the same problem?
Riccardo Ertolupi of the Vicenza Thunders Team: http://www.VicenzaThunders.com

DrAzzy

I just updated IDE to 1.0.6 on windows and the problem came back... with 1.0.5 worked wonderfully.
Anyone have noticed the same problem?
Probably have to reapply the same fix; I'll bet it overwrote the working version of the compiler tools with the same non-working one the IDE came with.
Please don't PM me questions or responses to my posts. I am unlikely to see or read them.

Go Up