Go Down

Topic: Arduino library for WTV020-SD-16P audio module (Read 114 times) previous topic - next topic

Schuppeste

If I have only one PlayVoice() call in my script .. I hear nothing .. The Example works without voice Play (0) ..

Can i use Play Voice (0); Play Voice (1) Play Voice (2);

I thought to play voice wait until the song is finished.


Megaionstorm

Has the library the ability to play wav-files ?
Mein Arduino Projekte Blog:
http://ardu-megatank.blogspot.de/

MacZap


Has the library the ability to play wav-files ?


Yes, but not stereo wav files

Peintre

thanks for this library. it works great.

and i can confirm that 16-bit mono wav files work with the WTV020-SD-16P.

just one question: what's the difference between playVoice() and asyncPlayVoice()?


begin1

Hello, I'm a beginner. could this device be controlled by a 4x4 keypad membrane instead of switch. In every key from the keypad it will play different wav files. Thanks in advance

alexw2150

maybe you can try SPI flash solution,it will response faster than SD card.

Is anyone aware of how to use the SPI interface for the WTV020-SD-16P audio module to put .ad4 files onto the on-board 64mb flash memory?

sibianul

Hello guys,

a friend of mine asked me if I can make something play very fast, a few times / second. A very short sound track to be played a few times / second, he wanted to be able to modify the repeat frequency. I don't have yet an audio module to test out the library, and I want to ask you

Is there any lag after the command to play a track ? can a very short track be played multiple times in a second ?

Thank you

skoubri

Trying with my module with no luck.. for two days now!...

Read all the thread and today i tested four SDs with ethernet shield.. the two of them (2GB) worked fine... the other two (4GB, 1GB) are not working...

The one of the two (2GB) is Kingston . Tried various formats but no luck... the unit is complete silent.. Only the LED after some seconds stay lit...

I am just wondering.. is there any other module maybe more "serious" out there to produce sound with arduino and especially with no gaps at loops?

Thanks in advance!

sibianul

... especially with no gaps at loops? ...


Please can you elaborate, this is what I'm curious too, but so far I can;t test as I don;t have any siund module .. is there any gap when looping a sound (even if the sound is very short) ?

knut_ny

I have had problems with theese chips. (still have)
I came over an idea (cant remember where) that 3,3V may be just to low to make this work.
A cellphone battery (3.6V) as powersupply had make it work as a standalone unit.
Ny

GoForSmoke


I have had problems with theese chips. (still have)
I came over an idea (cant remember where) that 3,3V may be just to low to make this work.
A cellphone battery (3.6V) as powersupply had make it work as a standalone unit.


If the 3.3V is low, check the 5V! You may have been dragging too much current through the board for its own good.
Check the power requirements of the module at full volume. If it needs more than 100mA then you probably should use external power, Arduino total should not exceed 200mA and best not to draw that much Through The Board.
Nick Gammon on multitasking Arduinos:
1) http://gammon.com.au/blink
2) http://gammon.com.au/serial
3) http://gammon.com.au/interrupts

skoubri

Yesterday arrived my second module as i have ordered some of them.. Identical to the first same type IC , etc...

It PLAYED just out of the box! Have the same behavior when plays(LED) so i think that the first one has something with audio output.. seems to play but not sound on the speaker or audio out pin.

But i am still looking for a "gapless" solution or the ability to have a long sound file and jumps into parts of it with no or very short delay...

winterwolf

Hi guys
I'm having problems with my wtv020 sound module. It seems that the LED blinks a few times, then stop blinking. But there is no output sound can be detected from the speakers. I'm using a two types of SD cards which is SanDisk 2GB MicroSD and SD-C02G microSD/T-Flash Card  Toshiba. I've copied the AD4 files form circuitstoday into the SD cards, so i assume there is no problem with the files.  Your coorperation is truly appreaciated =D

Schuppeste

Hardware Question,

how can i activate the 5-File keymode ?

boox44

hi, i bought 1 module WTV020-SD Micro SD Card mp3 but i have few problem to make it work, i real all the posts and i have not found solution ...

i use this tutorial : http://www.buildcircuit.com/mp3-mode-circuit-wtv020sd-16p-tutorial/ , i use the 3.3v power of the arduino and gnd to make it work...



First i use no name micro sd card 128mo and i try with a sandisk 2gb but the led don't  blink! do you know why?

i have a question, if the sd card is not compatible, the led blink or not with this schematic?

thanks for help

Go Up