Pages: 1 2 [3] 4 5 ... 14   Go Down
Author Topic: Arduino library for WTV020-SD-16P audio module  (Read 76433 times)
0 Members and 1 Guest are viewing this topic.
Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey, thank you very much guys for your greetings. I am really pleased that my little piece of source code did something useful. I have been out of this forum but I am back. First of all, when you have a problem with this sound module, 90% of the times, blame the uSD card. IT is VERY pesky about them. Later, could be the wired, and If everything else did not work, just replace the module.

About the gap, It depends entirely on the software and the module. It seems that needs 20 [ms] to switch between tracks. That's the gap you heard. I have been trying to fix that, but seems impossible given the hardware. I also moved the pin from 3.3 to 5 in one of my modules ( I have 2 of them) and did not work. Put 2 diodes, as recommended and worked, but no so fine. Any other moved the pin and got fine results?
Logged

ND-USA
Offline Offline
Newbie
*
Karma: 0
Posts: 2
ARDUINO
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can't find the zip file can give me that. smiley
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It is attached at the very first post. You have to be logged to see it.
Logged

ND-USA
Offline Offline
Newbie
*
Karma: 0
Posts: 2
ARDUINO
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oh ok THANKS got it
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Just let me know If you need anything else. Always a pleasure to help.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


FAT formatted on windows 7
File is named 0.ad4, and located in the root directory





use the sd card formatter utility, and rename the file as 0000.ad4

first try to use the ad4 files that have been tested by others , it will help u
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, congratulations for the work.
You can select a track between the files on the sd.
Create a sort of mp3 trigger.

 smiley smiley smiley
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey guys, anyone using it at 5V? Cause I moved the soldered pin from 3.3 to 5 and could not get it to work. Quite erratically. I did not use any diode cause I believe they are soldered in the pcb board. Any idea?
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Posted a new library here http://arduino.cc/forum/index.php/topic,133013.new.html#new for an audio amplifier that works with this audio module.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am running it on 5V supply without changing the jumper , and using 2 diodes.
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I am running it on 5V supply without changing the jumper , and using 2 diodes.
So, your board is working fine, cause I tried that setup and could not make it work. Functionality was erratically.
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You are abs right. Tried that with my two modules and did work. Maybe I tried that in the past with the defective one I had. Good!
Logged

Melbourne Australia
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Just a note in case anyone else tries this.

I bought one of these modules on eBay and following some instructions from someone on YouTube, I resoldered the jump link to set the voltage to 5V instead of 3.3V (there are 3 solder pads and you join 2 of them).

I did this because I could not get the module to make any sounds, even though the (busy) LED was flashing as if it was receiving commands etc.

Anyway. Following switching the module to 5V, it still didn't work, but when I tried to re-load the AD4 files, the SD card was no longer readable.

So it looks like the module may work on 5V, but not all SD cards (well not mine).
Hence I'd not advise anyone to try this unless the know their SD card is 5V tolerant.
 
Logged

Freelance web and iPhone app developer and Producer. Melbourne Australia

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Well, I don't think any micro sd card works at 5V. So, basically If does not work, It is not weird. If you need your wtv working at 5V, interconnect the diodes 4007 and go back that soldered pin to 3.3v.
Logged

Argentina
Offline Offline
Full Member
***
Karma: 5
Posts: 160
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Here you have the wtv working at 5V with two diodes:

Logged

Pages: 1 2 [3] 4 5 ... 14   Go Up
Jump to: