Go Down

Topic: Arduino library for WTV020-SD-16P audio module (Read 119900 times) previous topic - next topic

marklawrence

MAY I ASK SIR WHAT SHOULD I DO FOR THE P02,P03 AND P07 CONNECTIONS?

MY CIRCUIT DONT WORK.. AND THERE SEEMS TO HAVE AN ERROR IN THE PROGRAM? THANKS!

elac

#61
Jan 09, 2013, 12:40 am Last Edit: Jan 09, 2013, 08:30 pm by elac Reason: 1
For the pins you mention:
1. You can hook them up to buttons like the schematic shows, for manual control of tracks.
2. You can leave them disconnected and unused (maybe use 0.1uf ceramic cap to grnd).

As for the program you are using and what you are trying to accomplish, you must post that if you want help with it.

And please stop SHOUTING.   ;)
It's all about the skills

Balisto

i cant get my own soundfiles to work with this module.
Can anyone tell me the exact settings to convert an mp3 into an ad4 file?
Must the mp3 mono? Which sampletype? Bitrate and so on must the source mp3 or wav??
the original sample files works fine!!

roan861

Hey.
I can't download library in this topic.
Link isn't working:
"Error 503 Service Unavailable"
Where can i download this Library?

ericspags

I'm having the same issue, can anyone that has it re-upload the library?

the-rebel-agent

Will re-upload the library this night from home.


the-rebel-agent


ericspags

Unfortunately I still cannot access the library, clicking the link still pulls up the same error page.

EA3BIL

Hi Rebel, (and all the readers aswell...  ;) )

I downloaded right now the library and when unpacked I see TWO identical files.

One of them named: Wtv020sd16p.cpp
Another one named: Wtv020sd16p.cpp~
Both them 2183bytes.

Is that correct??

Gracias,
Rafa.

purgedsoul

I think it's okay, the Wtv020sd16p.cpp~ might just be a temporary file that was not deleted.

Thanks to Rebel for the Library! I got it to work on my module, after trying several SD-Cards. Talk about this thing is picky with SD-Cards.

Does anyone have any idea on how to interrupt the currently playing voice, and play another one when a button is pressed?

I tried modifying rebels playVoice function into:

Code: [Select]

void Wtv020sd16p::playSound(int voiceNumber){ 
if (_busyPinState==HIGH) {
  sendCommand(STOP);
}
else {
sendCommand(voiceNumber);
}
  _busyPinState=digitalRead(_busyPin);
  while(_busyPinState==HIGH){
    _busyPinState=digitalRead(_busyPin);
}
}


it checks for the busy pin's state, if it is HIGH, send the STOP command, and then play the voice.

Unfortunately it does not work. Or i'm just not doing it right.


the-rebel-agent

For those wondering how this audio module works with music, here you have an example:

http://www.youtube.com/watch?v=_RGRAhex7Zs

By the way, everything is now working with 3.3v. I just bought a new Mini Pro working at 8Mhz 3.3V, downloaded the same program I did for the previous Arduino and tada, worked out like a charm.

xl97

nice job!..

the only difference should be the audio files you use now.. (making sure it for a 8MHz instead of 16Mhz)  :)

now you just gotta merge everything together (Arduino, Amp, SD card) into one awesome, tiny board!!!  :)

this is gonna go great for the "V" project. :)

the-rebel-agent

As a matter of fact, audio files are the same rate. There's no need in change them.
And yes, if will be a great project for the v community

Go Up