Pages: 1 2 [3]   Go Down
Author Topic: Transformador para alimentar servo y placa arduino uno  (Read 8175 times)
0 Members and 1 Guest are viewing this topic.
Malaga
Offline Offline
Sr. Member
****
Karma: 6
Posts: 319
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si
Logged

Vinciduino rocks!

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 40
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Jopeta, eso de que "... es de los que más sabe de por aquí...", es poner mucho peso en mi espalda smiley-sad

A ver, nunca me ha gustado asumir que la electrónica con la que me conecto han puesto su correspondiente circuitería de protección (lo he aprendido cometiendo el mismo error en alguna ocasión y el señor del humo a venido a recordármelo). He visto muchos servos de modelismo y los baratos chinos no llevan su correspondiente diodo de protección. Por el contrario, Futaba, HiTech, tienen la fea manía de hacerlo bien y se los ponen.

Como decían en mi pueblo (es que soy de un pueblo de unos 100 habitantes - hay más cabras que personas -): ante la duda la más tetuda.
Logged

   

Offline Offline
Newbie
*
Karma: 0
Posts: 44
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

entonces no pondré el condensador 100nf, Según estoy leyendo creo el Servo Hs311 viene ya con la protección incluida en su circuito por lo que no haría falta añadir ni diodo ni condensador, ahora mismo no me mete ningun ruido ni temblor de la manera que lo tengo, directamente alimento la placa con un transformador de 9v y el servo lo  alimento con los 5v y gnd de la placa arduino
Logged

Malaga
Offline Offline
Sr. Member
****
Karma: 6
Posts: 319
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Una cosa es que el servo tenga protección interna ... y otra cosa es que no meta ruido en la linea de alimentación (con ruido no nos referimos a que empieces a escuchar los beatles sonando en el circuito ... para ver el ruido necesitas un osciloscopio o un medidor de RMS).

El condensador (de 10-100uF, no nanos, nunca está de más ...)
Logged

Vinciduino rocks!

Offline Offline
Newbie
*
Karma: 0
Posts: 44
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

me funciona perfectamente sin ningun tipo de ruido, monté otro circuito de manera diferente con el mismo  servo que estoy utilizando
y al pulsar on el servo metía un ruido electrico cojonudo al pulsar off cuando dejaba de mandar señal apagando el interruptor se quitaba
y al montar un nuevo circuito de manera diferente me va bien y ya no me lo hace pero bueno como bien dices si no está de más ni va a molestar
pues mejor le pongo un condensador
gracias
Logged

Malaga
Offline Offline
Sr. Member
****
Karma: 6
Posts: 319
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Más que ruido, lo que te metía era una orquesta sionfóncia entera ... yo esto hablando de ruido de 50 -100 mV
Eso ni lo notas, hasta que no ves oscilar las capturas analógicas ...
Logged

Vinciduino rocks!

Offline Offline
Newbie
*
Karma: 0
Posts: 44
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Exactamente este ruido:

http://www.youtube.com/watch?v=GFsFEODigzQ&feature=youtu.be

no tengo ni idea de que podía ser pero probé con otro circuito diferente y otro código y como digo ya no hace ningún tipo de ruido,
alguna vez que no queda bien fijado el potenciometro si pero vamos ya me funciona bien, le pondré el condensador por si las moscas
y listo
Logged

Pages: 1 2 [3]   Go Up
Jump to: