Go Down

Topic: Port/Serial issues with PHP/Shell (Read 764 times) previous topic - next topic


Hi guys, so I've been having an issue that's been baffling me. So I'm basically using code to shoot a nerf gun and I started out trying to use serial PHP and it would hang up and freeze stuff up so I switch to a shell script, it worked great. Then I tried to use serialphp class again and got it to work. I then try to alter the code slightly and it started doing the same thing again, hanging up. now I can't even get it back to where it was or simply working with the shell script, which hasn't changed.

When I send a command with shell it just blinks the 13 pin led twice and does nothing. If I try to use the shell or php script it locks up the arduino software and doesn't allow me to upload a new sketch, it just get's stuck on uploading. It seems like there's an interference on the port, any Ideas?


It seems like the only thing that works is if I first communicate with the arduino through the serial monitor then I can use php or shell... very strange..


The art of getting good answers lies in asking good questions.


While it makes some sense, that wouldnt explain why it wouldn't work in shell file. The shell file is behaving exactly the same as the php.serial class.


any Ideas?

Possibly bad code or flawed expectations.
Google forum search: Use Google Search box in upper right side of this page.
Why I like my 2005 Rio Yellow Honda S2000  https://www.youtube.com/watch?v=pWjMvrkUqX0

Go Up