Go Down

Topic: Consulta de Problemas de Electricidad (de un pre-novato) (Read 7 times) previous topic - next topic

fm

Otra cosa importante a tener en cuenta. Si bien es cierto que el AVR es capaz de suministrar 40mA por salida, también es cierto que el máximo que todas sus salidas son capaces de suministrar es de tan solo 200mA. Por lo tanto, no lo fuerces. Si ves que vas a conmutar más corriente utiliza transistores para conmutar.
No os podéis imaginar la de AVRs que he visto fundidos por este foro.
   

Razorblade

#11
Aug 12, 2012, 01:44 pm Last Edit: Sep 17, 2012, 12:27 pm by Razorblade Reason: 1
Bueno pues ya que estamos, ¿dónde se podría conseguir un transformador a 6.5V/1A que sea fiable? No es algo 'trivial' para los que somos de apueblo.

En mi caso, tengo una pantalla táctil a 5V de 4D Systems que cuando accede a la tarjeta uSD o reproduce un sonido desde ésta traga picos que llegan tranquilamente a 600mA.

Alimentando con un transformador anónimo de 12V/1A al Arduino+Ethernet, y derivando a un regulador 7805 para la pantalla, funciona todo OK, pero como es de esperar los reguladores de Arduino y el 7805 cogen unas temperaturas que más de 2 minutos conectado y habría un incendio ahora en verano.
Probé con otro transformador anónimo que ponía 5V/1A, alimentando directamente a 5V de Arduino y a la pantalla sin reguladores, pero como era de esperar con esa marca (o lo mismo de marcas Chinolaesquina), de 5V contínuos los coj.. :smiley-sleep: Ni se enciende la pantalla.
También he probado con un transformador 5V/700mA de un móvil ZTE, que ahí se nota la calidad y sí que aparentemente funciona todo OK (además es ideal porque la salida es conector USB), pero a veces la pantalla se reinicia (porque 700mA para todo se quedan cortos), y veo que el transformador sufre algo porque se calienta un poquitín comparado con su uso para cargar baterías.


Por tanto efectivamente es un tema complicado encontrar la alimentación adecuada.



Edito: Creo que tengo a un candidato perfecto. El cargador de la PSP, marca Sony y 5V/2A, que lo tengo a mano. Acabo de pedir por eBay un conector hembra para soldarle un cable con hembra USB cable jack DC hembra <-> USB hembra, y no tener que destrozar el cable del cargador.
Arduino Uno (R2fix) / Duemilanove (328p)
Ethernet Shield SD (v5)

Razorblade

Confirmado, el cargador de la PSP mantiene unos 4.8V como un campeón sin calentarse, y el Arduino + Ethernet + pantalla táctil que consume como un demonio funcionan perfectamente.
Arduino Uno (R2fix) / Duemilanove (328p)
Ethernet Shield SD (v5)

Gre3nLioN

Hola, soy otro novato en este tema y vengo a hacer preguntas triviales :smiley-eek: .
(lamento revivir un viejo post, pero me pareció el lugar mas indicado).

Me compre el mismo Kit que el creador del post.
Arduino MEGA :
http://arduino.cc/en/uploads/Main/ArduinoMega2560_R3_Front_450px.jpg

La shield sensors para arduino MEGA V1.0:
http://www.dfrobot.com/wiki/images/5/5c/Mega_IO_Expansion_Shield_For_Arduino_Mega2.jpg

Note que la shield tiene para conectar tensión y la placa Arduino MEGA también.

A cual debería conectarle la tensión a el arduino MEGA o a la Shield Sensors? con conectarle a una de los 2 estaría bien? de ser así, podría conectarle a la shield directamente y no a la placa arduino?, o tengo que darle tensión a ambos? (de ser asi, con darle 6V a cada uno tendría que funcionar?)
Mi suposición es que con conectar una de las dos a tensión deberían funcionar, pero no quiero arriesgarme y quemar mi nuevo juguete :)

El consumo del shield va a ser:
3 servos chicos (4/6V 1.5kg torque)
1 ultrasonic sensor
X cantidad de leds
1 SD card reader

En el futuro quisas mas servos, pero por ahora seria eso :)

Y ya que estoy hago una pregunta conceptual de esta Shild.
Lo único que hace es reorganizar los inputs del Arduino MEGA y ponerle cerca  positivo y tierra para una mas fácil coneccion, o tiene alguna otra ventaja?

Desde ya gracias, Suerte!

mirasu

Yo creo que tienes que alimentar el mega. porque lo otro parece que no tiene regulador de alimentacion o no se ve.

A mi e gustaria preguntar tambien una cosa.

Tengo un mega y lo he probado alimentar con un cargador de una linterna de 12v DC y 300mA ya se que es poco. pero lo raro es que se calienta el regulador del mega y los condensadores y no el transformador.
el positivo esta en el centro del conector.

Es normal? es porque el transformador es de poca potencia? si pongo uno mas potente no quemare el regulador del mega?

Gracias!

Go Up