Go Down

Topic: How to program ATtiny45 with Arduino Leonardo as ISP (Read 18027 times) previous topic - next topic


Well, since johntech2011 is on windows xp, I tried things out on that os (I used win xp pro sp2). Guess what, it did not work. The work around so use -c arduino (http://arduino.cc/forum/index.php/topic,108270.msg1013258.html#msg1) does not help either.

More in general communication over the leo's virtual com port does not work at all: error writing to serial port (tried putty, ide's serial monitor and avrdude) This is strange  since uploadng sketches to the leo's bootloader does work correctly. So this must be caused by the leo's core which works very well with linux but really has some problems with windows.

I want to figure this out but it does not look very good. All ideas are welcome.


Dec 12, 2012, 10:17 am Last Edit: Dec 12, 2012, 10:21 am by johntech2011 Reason: 1
Thank you for verifying that Peter. That was driving me nuts as everything I found said it would work. Believe me I tried a lot of things. Once I purchased the Uno ver 3 it worked the first time.



Thanks for everyone.I did try on ATMEGA 168 and it works.



I know this is resurrecting a very old thread, but I just wanted to thank PeterVH for his work.
I couldn't get my ProMicro copy (32u4) to work properly as an ISP.
After adding the file "programmers.txt" as Peter outlined in his Wordpress article, everything started working fine.
I am using Windows 7 64-bit and Arduino 1.0.5 and nothing but Peter's workaround helped.
Thanks again. 8)


I also get the error message

avrdude: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

on both ATtiny45 and 85
using an UNO rev.3
(and win 7 - if that helps)
does anybody know the solution already?

Coding Badly

avrdude: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

You have the wrong board or wrong programmer selected.


OMG Thank you sooo much PeterVH this solution works perfect in my case, i searched like 2 hours until now.

Go Up