Go Down

Topic: [MOD] Arduino Enhanced Release 1.0.5 for Windows (installer, drivers, etc) +SRC (Read 257 times) previous topic - next topic

AlxDroidDev


What Louis Davis says seems to be correct. You maybe require the JDK in 32 bits. About: "AVRdude version 5.10 instead of the newer 5.11" can you tell me how to check this, I am still confused since you (or someone) commented this weeks ago.


Thanks. I'll try and install the 32-bit JRE.

To check the version of AVRdude, just run (from a command prompt):

avrdude -?


the version is the very last info shown, and with version <=5.10, the results are a bit garbled in the screen (it is neat in 5.11).
Learn to live: Live to learn.
Showing off my work: http://arduino.cc/forum/index.php/topic,126197.0.html

eried



PS: I will try to add the new features.


In case you run out of idea: a "remove trailing spaces" pre pass could be added to the auto format source code.


Any example?
My website: http://ried.cl

hole

Type any line of text, then hold the space key. It will add spaces at the end of the line.   :)

It does no do any harm to keep them there, but I find it annoying. So I like to clean up. Especially if I release code.

Notepad++ -> TextFX -> Trim Trailing Spaces does it for me.

modeller

When I open the IDE I get an empty window. If I then go and open one of my programs it opens yet another window. Is there any setting that will stop the second window from opening. I just want the code to appear in the window that starts when the IDE starts. I looked at the preferences file and didn't see anything that looked like the setting I needed.

eried


Type any line of text, then hold the space key. It will add spaces at the end of the line.   :)

It does no do any harm to keep them there, but I find it annoying. So I like to clean up. Especially if I release code.

Notepad++ -> TextFX -> Trim Trailing Spaces does it for me.


Ah, ok, it's doable.


When I open the IDE I get an empty window. If I then go and open one of my programs it opens yet another window. Is there any setting that will stop the second window from opening. I just want the code to appear in the window that starts when the IDE starts. I looked at the preferences file and didn't see anything that looked like the setting I needed.


I can research this.


So, pending stuff to add/research until now (ideally for the 1.0.4 update):
-remove trailing spaces
-reuse window
-upload hex option
-change to Source Code Pro font
-some fixes from Energia -> Arduino (like 8.3 naming issue to remove the requeriment of PATH modification, some selection issues)
-check avr compiles version
My website: http://ried.cl

Go Up