Go Down

Topic: [MOD] Arduino Enhanced Release 1.0.5 for Windows (installer, drivers, etc) +SRC (Read 277206 times) previous topic - next topic

hole

Try this:

enter this into the IDE:

Code: [Select]

int blah;                                        // some comment


Now delete the comment starting with the //.

Code: [Select]

int blah;                                       


If you press POS1 your cursor jumps to the begin of the line.

Code: [Select]

|int blah;                                       


If you press END your cursor jumps to the end of the line.

Code: [Select]

int blah;                                       |

eried

I see what you mean, I will fix this, and try to implement the "upload hex" and then publish an update :)
My website: http://ried.cl

AlxDroidDev


I see what you mean, I will fix this, and try to implement the "upload hex" and then publish an update :)


Eried,

I understand you might be quite busy, but is there any chance any of my other suggestions be implemented? Specially the ability to explicitely specify the JRE folder to be used. Thanks.
Learn to live: Live to learn.
Showing off my work: http://arduino.cc/forum/index.php/topic,126197.0.html

eried



I see what you mean, I will fix this, and try to implement the "upload hex" and then publish an update :)


Eried,

I understand you might be quite busy, but is there any chance any of my other suggestions be implemented? Specially the ability to explicitely specify the JRE folder to be used. Thanks.


Sure I can but, I need you to develop a little more your idea: Where this option should be? Can you do some tests running the IDE without the exe? (google for the bat and open the pde.jar), can you provide the 2 working bat files so I can fix the launcher? (the problem in this case probably resides on the launcher, not in arduino)
My website: http://ried.cl

copet_pitik

:smiley-eek:  :smiley-eek: Hello World  :smiley-eek:  :smiley-eek:

Hello Eried,
I have a problem implementing how to fix a arduino blurry icon in win 7 taskbar
i downloaded your tutorial from here: http://servicios.ried.cl/arduino/temp/windows7_arduino-1.0.1_fix.rar
and when i try the 4th step, and run arduino it say:
Code: [Select]
"Could not read default settings.
You'll need to reinstal Arduino."

i also tried to replace the "awt.dll" in the "java/bin" folder
but nothing is solved so far.

P.S:
I am using Arduino 1.0.3
sorry if my English is bad
:smiley-eek:  :smiley-eek: Hello World  :smiley-eek:  :smiley-eek:
Program Studi Instrumentasi Medis
Politeknik Mekatronika Sanata Dharma
Yogyakarta Indonesia

eried


:smiley-eek:  :smiley-eek: Hello World  :smiley-eek:  :smiley-eek:

Hello Eried,
I have a problem implementing how to fix a arduino blurry icon in win 7 taskbar
i downloaded your tutorial from here: http://servicios.ried.cl/arduino/temp/windows7_arduino-1.0.1_fix.rar
and when i try the 4th step, and run arduino it say:
Code: [Select]
"Could not read default settings.
You'll need to reinstal Arduino."

i also tried to replace the "awt.dll" in the "java/bin" folder
but nothing is solved so far.

P.S:
I am using Arduino 1.0.3
sorry if my English is bad
:smiley-eek:  :smiley-eek: Hello World  :smiley-eek:  :smiley-eek:



You don't need that fix. Is bundled in this version. (also the fix is for 1.0.1, not 1.0.4)
My website: http://ried.cl

Hey eried,

By mistake i installed both the non-java version and Recommended version of your Enhanced Arduino 1.0.4 Package.
After a restart, one of the versions lost the Arduino icon, and shows up with "Unknown File" icon instead.
I have removed both and installed each one again, but i cant seem to get my Icon Back...

What to Do??

Regards

The Icon is like this, and it is the same way in Program Files (x86)/Arduino folder.

EDIT: I am on Windows 7 x64. Please Help.


eried

Manually delete the link from the desktop and then install the version you want (since both versions use the same link, the second one "respected" the existing icon, so it didn't removed it on the unninstall)
My website: http://ried.cl

copet_pitik



:smiley-eek:  :smiley-eek: Hello World  :smiley-eek:  :smiley-eek:

Hello Eried,
I have a problem implementing how to fix a arduino blurry icon in win 7 taskbar
i downloaded your tutorial from here: http://servicios.ried.cl/arduino/temp/windows7_arduino-1.0.1_fix.rar
and when i try the 4th step, and run arduino it say:
Code: [Select]
"Could not read default settings.
You'll need to reinstal Arduino."

i also tried to replace the "awt.dll" in the "java/bin" folder
but nothing is solved so far.

P.S:
I am using Arduino 1.0.3
sorry if my English is bad
:smiley-eek:  :smiley-eek: Hello World  :smiley-eek:  :smiley-eek:



You don't need that fix. Is bundled in this version. (also the fix is for 1.0.1, not 1.0.4)


Okay, thanks Eried..
Program Studi Instrumentasi Medis
Politeknik Mekatronika Sanata Dharma
Yogyakarta Indonesia

@eried,

Thanks a lot...! Problem Solved.
Uninstalled, Rebooted, reinstalled and it worked like a charm.

Regards

dawiz711

I just had to say thanks, fought with the standard release for a sad amount of time before I found this. One liter of Pepsi coming your way my friend, my night just got alot better!

BobbyD

Eried ,
This installed perfectly. I have been trying to program ATTiny 85 for several days and run into a brick wall. I followed the same instructions with your 1.0.4 and it worked without a hitch .

Thank you for sharing !
BobbyD


eried


Try this:

enter this into the IDE:

Code: [Select]

int blah;                                        // some comment


Now delete the comment starting with the //.

Code: [Select]

int blah;                                        


If you press POS1 your cursor jumps to the begin of the line.

Code: [Select]

|int blah;                                      


If you press END your cursor jumps to the end of the line.

Code: [Select]

int blah;                                       |



Okay! it's Auto-format fixed now. Enjoy!


@eried,

Thanks a lot...! Problem Solved.
Uninstalled, Rebooted, reinstalled and it worked like a charm.


Regards


Eried ,
This installed perfectly. I have been trying to program ATTiny 85 for several days and run into a brick wall. I followed the same instructions with your 1.0.4 and it worked without a hitch .

Thank you for sharing !
BobbyD




I just had to say thanks, fought with the standard release for a sad amount of time before I found this. One liter of Pepsi coming your way my friend, my night just got alot better!


Nice it worked fine for all of your machines.

PD: My pepsi stash is full for now! :D

My website: http://ried.cl


nid69ita

Thank you for sharing. Very good.

An question.
Do you think it's had to implement an intellisense for IDE editor like codeblock or visual studio ?

my name is IGOR, not AIGOR

Go Up