Pages: 1 ... 11 12 [13] 14 15 ... 42   Go Down
Author Topic: [MOD] Arduino Enhanced Release 1.0.5 for Windows (installer, drivers, etc) +SRC  (Read 250956 times)
0 Members and 2 Guests are viewing this topic.
Offline Offline
Sr. Member
****
Karma: 6
Posts: 429
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Changing the font back to System,plain,14 made no difference to the serial monitor output, I had to edit the prefs text file as the system font does not appear in the prefs GUI dropdown.

Both prefs setting are editor.font=System,plain,14 and editor.antialias=false



Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Changing the font back to System,plain,14 made no difference to the serial monitor output, I had to edit the prefs text file as the system font does not appear in the prefs GUI dropdown.

Both prefs setting are editor.font=System,plain,14 and editor.antialias=false

OK I see, but can you replicate the problem with a simple sketch? I need some guesses about what is producing the problem because I didn't added too much to the serial routine, only some conditions:


My first guess is maybe at that rate, java speed is so crappy that it loses chars? can you test at lower/higher speed?
Logged

My website: http://ried.cl

Offline Offline
Sr. Member
****
Karma: 6
Posts: 429
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Even with a delay of half a sec, the serial.prints are not seen until you press the reset button.

Code:
int sleep = 500;
void setup()
{

  Serial.begin(57600);
  delay(sleep);
  Serial.println();
  delay(sleep);
  Serial.println("Code to Replicate ArdunioERW Serial Monitor Bug.");
  delay(sleep);
  Serial.println();
   delay(sleep);
  Serial.println("Serial Connected");
  delay(sleep);
  Serial.println();
}

void loop()
{
{

Here`s another with some code in the main loop.
The loop should pause waiting for some serial input, but does not.
Sometimes a line of random chars appears before anything else is seen.
Code:
int sleep = 500;
void setup()
{

  Serial.begin(57600);
  delay(sleep);
  Serial.println();
  delay(sleep);
  Serial.println("Code to Replicate ArdunioERW Serial Monitor Bug.");
  delay(sleep);
  Serial.println();
   delay(sleep);
  Serial.println("Serial Connected");
  delay(sleep);
  Serial.println();
}
 


void loop()
{
  byte t = 0;
  Serial.println();
  delay(sleep);
  Serial.println("Please type a single number into the serial monitor.");
  delay(sleep);
  Serial.println();
   delay(sleep);

  while(!Serial.available())     // Do nothing while waiting for input.
  {  }
  byte num;
   t = Serial.read();
    if (t  >= '0' &&  t <= '9'){
      num = (t - '0');
    }
     Serial.print("Number Converted to ");
     Serial.println(num);
     Serial.read();  //discard nl char sent

Both these work correctly in the original serial monitor.
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This is weird, I tested the first one and I still can't replicate the issue, did you edited something else? like the boards.txt?



No reset, or anything, just upload and open the monitor. Can another user please check this?
« Last Edit: October 24, 2012, 02:58:02 pm by eried » Logged

My website: http://ried.cl

Offline Offline
Sr. Member
****
Karma: 6
Posts: 429
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Don`t know where the boards.txt file is stored, the text file I`ve looked at is the prefs file which is stored in Application\data\Arduino
I`ve changed editor.window.height.default=800 and editor.antialias=false

I suppose it could be something odd with my PC, I`ll try it on the laptop later.

Ok, I`ve just tried a compile with the incorrect board selected and did not get an error, that can`t be right!

I`ve not done anything to change this file.

Can I copy the original boards.txt to replace yours?
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Don`t know where the boards.txt file is stored, the text file I`ve looked at is the prefs file which is stored in Application\data\Arduino
I`ve changed editor.window.height.default=800 and editor.antialias=false

I suppose it could be something odd with my PC, I`ll try it on the laptop later.

Ok, I`ve just tried a compile with the incorrect board selected and did not get an error, that can`t be right!

I`ve not done anything to change this file.

Can I copy the original boards.txt to replace yours?

Yes, the only thing is the definition of the ram per board. You will get a warning without the boards.txt I used
Logged

My website: http://ried.cl

Greenville, IL
Offline Offline
Edison Member
*
Karma: 15
Posts: 1330
Warning Novice on board! 0 to 1 chance of errors!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

 Using his sketch, it seemed that bringing up the serial monitor does not reset the Arduino like I am normally see.

I changed the sketch, and I can see the message if I get the monitor open before the first delay() is over. After the delay is over, the monitor does not reset the board so, a reset is required.
EDIT: this is with version H on windows 7.

Altered the first delay to 5000.:
Code:
int sleep = 500;
void setup()
{

  Serial.begin(57600);
  delay(5000);
  Serial.println();
  delay(sleep);
  Serial.println("Code to Replicate ArdunioERW Serial Monitor Bug.");
  delay(sleep);
  Serial.println();
   delay(sleep);
  Serial.println("Serial Connected");
  delay(sleep);
  Serial.println();
}

void loop()
{
}
Logged


Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Using his sketch, it seemed that bringing up the serial monitor does not reset the Arduino like I am normally see.

I changed the sketch, and I can see the message if I get the monitor open before the first delay() is over. After the delay is over, the monitor does not reset the board so, a reset is required.
EDIT: this is with version H on windows 7.

Altered the first delay to 5000.:
Code:
int sleep = 500;
void setup()
{

  Serial.begin(57600);
  delay(5000);
  Serial.println();
  delay(sleep);
  Serial.println("Code to Replicate ArdunioERW Serial Monitor Bug.");
  delay(sleep);
  Serial.println();
   delay(sleep);
  Serial.println("Serial Connected");
  delay(sleep);
  Serial.println();
}

void loop()
{
}

Yes but the reset is not something I am trying to keep, that's more like a bug of the official IDE due old RXTX lib
« Last Edit: October 24, 2012, 07:51:03 pm by eried » Logged

My website: http://ried.cl

Offline Offline
Sr. Member
****
Karma: 6
Posts: 429
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Without that reset, after an upload, the serial monitor does not behave in a consistent manner (on my PC).

Some times it behaves and prints what you send to it, sometimes its blank, and other times I see this..
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Without that reset, after an upload, the serial monitor does not behave in a consistent manner (on my PC).

Some times it behaves and prints what you send to it, sometimes its blank, and other times I see this..


You renamed avrdude2 right?

The serial flush is handled by the wrapper now, not the ide (the wrapper checks if the port is working or 'hang'), can you test installing the last version? I can add some kind of "old" emulation mode token for the preferences, but I need to see if other users are getting the same issue
Logged

My website: http://ried.cl

Offline Offline
Sr. Member
****
Karma: 4
Posts: 327
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I seem to remember there being quite a few 'features' with the arduino and resets,
    and various versions of the boards have various hardware fix's.

dont know, but could it be that you both have different versions of the boards ?

just a thought.

now if you were part of the official arduino team, you might get lots of hardware,
    we can but hope you get adopted by them soon,

Logged

Offline Offline
Sr. Member
****
Karma: 6
Posts: 429
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Without that reset, after an upload, the serial monitor does not behave in a consistent manner (on my PC).

Some times it behaves and prints what you send to it, sometimes its blank, and other times I see this..


You renamed avrdude2 right?

The serial flush is handled by the wrapper now, not the ide (the wrapper checks if the port is working or 'hang'), can you test installing the last version? I can add some kind of "old" emulation mode token for the preferences, but I need to see if other users are getting the same issue
The only thing I`ve changed is the prefs file as stated in a previous post, no other file has been altered.

You want me to install version 1.0.1h? (just to be clear as to what I`m doing).
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This is great, I was having a lot of issues opening the tool menu and this looks like it solved a lot more than that. Thanks!
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You want me to install version 1.0.1h? (just to be clear as to what I`m doing).

That one also uses the avrdude wrapper, I will love to see another machine/user having the same problem. I just need to find the root of the issues. The serial monitor is rather simplistic, it only dumps the text arduino sends so really I am clueless right now.

I seem to remember there being quite a few 'features' with the arduino and resets,
    and various versions of the boards have various hardware fix's.

dont know, but could it be that you both have different versions of the boards ?

just a thought.

now if you were part of the official arduino team, you might get lots of hardware,
    we can but hope you get adopted by them soon,


Hehehe of course free hardware is always good, but I don't think it works that way. I have couple boards (like 12 or so) but still no leonardo or due to test (I haven't required any of these)

This is great, I was having a lot of issues opening the tool menu and this looks like it solved a lot more than that. Thanks!

You are welcome! that's the idea smiley-grin
Logged

My website: http://ried.cl

Offline Offline
Sr. Member
****
Karma: 6
Posts: 429
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Works fine with Hyperterminal.


A couple of times now the IDE has frozen while uploading.


Not getting an error message when the incorrect board is chosen.
Logged

Pages: 1 ... 11 12 [13] 14 15 ... 42   Go Up
Jump to: