Go Down

Topic: CapSense e Attiny... FINE!!!! : ) (Read 8 times) previous topic - next topic

Michele Menniti



Allora, i led sono da 3mm, sono 8 led collegati in parallelo...  non ho sotto mano il circuito... oggi posto un altro schema, guardando filo per filo sulla scheda...

Se li hai collegati in parallelo, e sono 8, con 5V è normale che non li accendi neanche...

e perché mai? il discorso varrebbe se fossero messi in serie, in parallelo l'unica differenza non è nella caduta di tensione, che è sempre quella di un solo LED, ma della corrente assorbita, che si va a molitiplicare per otto.

Quote

Il BC337 è un NPN quindi se lo hai montato come nello schema è alla rovescia.

verissimo!

Quote

Quote

La resistenza da cambiare è quella del sensore?

Sì, parlavo di quella.

ma comunque, in base alla caratteristiche dei LED, una R sul collettore del Transistor è indispensabile per la limitazione di corrente, altrimenti i LED alla lunga saltano.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72


e perché mai? il discorso varrebbe se fossero messi in serie, in parallelo l'unica differenza non è nella caduta di tensione, che è sempre quella di un solo LED, ma della corrente assorbita, che si va a molitiplicare per otto.

E' vero, ed essendo alimentati da un transistor sarebbe al massimo un problema dell'alimentatore.


Quote

ma comunque, in base alla caratteristiche dei LED, una R sul collettore del Transistor è indispensabile per la limitazione di corrente, altrimenti i LED alla lunga saltano.

Mi pareva ci fosse: la R da 1K dovrebbe andare sulla base. Però andrebbero fatti i conti sulla corrente assorbita dagli 8 led per vedere se come valore basta.

maggio93

BUONE NOTIZIE!!!! :D Ho collegato la terra al negativo dell'alimentatore e funziona anche se volo!! :D E per la resistenza sui led ho messo un trimmer sul positivo dei led e l'ho messo messo a 10ohm i led non ballano più!!! :D Per adesso non ho più problemi... appena finito il tutto posto le foto e i video!!
E se ho qualche altro problema torno da voi!! Grazie mille!! :D

Michele Menniti

Giusto per fare una cosa secondo norme e regole:
hai il data-sheet o le caratteristiche di massima dei LED che stai usando?
Hai controllato se il transistor è montato in modo corretto, penso di sì, ma per scrupolo....
Il collegamento della terra al negativo dell'alimentazione non è una bella manovra, non sia mai si verifica una dispersione sulla 220Vac ti trovi l'alternata sul circuito, che diverrebbe a quel punto una trappola infernale, altro è se la colleghi alla carcassa metallica della lampada, ma non dovrebbe entrare in contatto con nessuna parte del circuito, è troppo pericoloso!
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

maggio93

Allora, i dati dei led sono i seguenti:
Code: [Select]
Emitting color: White
Diameter: 3mm
Lens color: Water clear
Forward Voltage(V): 3.2-3.4
Current(MA): 20
View angle: 25
Luminous intensity(MCD): 14,000 - 16,000

Per il transistor devo ancora controllare... ieri ho perso così tanto tempo a trovare un modo per far andare il tutto che non ci ho più pensato...
Allora.......Guarda qui!!

Questa è la lampada sulla quale mi sono basato per fare la mia... Il fondo del telefono è di metallo, il tubo che tiene su la cornetta anche. Il sensore è attaccato sul tubo, ma visto che il tubo e il fondo del telefono sono a contatto è come se avessi il sensore in qualsiasi punto del telefono...Ora, se io attacco la terra sulla carcassa è come attaccarlo al sensore... E ho già fatto questa prova, la lampada impazzisce!!!! Si accende e si spegne da solo continuamente... L'unica soluzione è stata della della terra sul meno...

Go Up