Go Down

Topic: Im having a problem with new ATMega328 (Read 422 times) previous topic - next topic

Justniv

Hi everyone, I've got Arduino Uno, and im a BIG noob.  :smiley-eek:
i want to "put" my new chip atmega328 on a breadboard (like here- http://arduino.cc/en/Main/Standalone), so i gussed i need to burn bootloader.
I tried this tutorial: http://arduino.cc/en/Tutorial/ArduinoToBreadboard
But i got this error: avrdude: stk500_getsync(): not in sync: resp=0x0
then i tried this tutorial: http://www.3guys1laser.com/blog-burn-bootloader-blank-atmega328atmega328p-arduino-uno
But i got the same error: avrdude: stk500_getsync(): not in sync: resp=0x0
I think im doing somthing wrong, it cant be that nothing works for me. What am i missing??
I'll appreciate any help. Thanx :)

MarkT

Firstly that tutorial misses out decoupling capacitors from the breadboard circuit - these are required components.  Search on this forum for details.

You should _not_ power the breadboard from pin9 as in the second example, this could blow your original 328.

Provide the crystal and caps anyhow in the second tutorial as you may have re-fused the chip in the first attempt.

If you can't get the Uno bootloader to upload, try selecting Duemilanova board on the Arduino software just before the "Arduino as ISP" step - this will attempt to put the older bootloader onto the chip.

You have of course successfully programmed the Uno with the ArduinoISP sketch (with the board set to Uno)?  This turns the Uno into a device to program another chip with any bootloader.

What is the exact chip number on the 328 you have BTW?  "ATMEGA328P-PU" I hope.
[ I won't respond to messages, use the forum please ]

Go Up