Go Down

Topic: 6 DOF Combo IMU (Read 584 times) previous topic - next topic

RobertEagle

Hi guys,

I have a sensor board with 2 chips on it: ADXL345 and ITG3200. As it is, the board has 2 INT pins, a GND, a 3.3V pin and I2C pins (SDA, SCL).

For almost all day I've tried to make it work, but with no success. I've connected the board to the Arduino Duemilanove with 4k7 resistors and then with 2k2 resistors and then with no resistors thinking that the Arduino has those built-in resistors made specifically for the Wire.h. Nothing worked.

Then I've switched the boards. This time I took an Ardupilot Legacy with Atmel328. Again, the same configurations, with no chance of working. I've took care of the connections and tutorials, so with no doubt, I didn't make any connection mistake.

I've tried 4 or 5 sketches found on the internet specifically made for this IMU(all were working on others). Some of them were giving somehow random values and other nothing on the serial window. I thought making my own program would be inappropiate in this situation. It's basically the same. With minor changes, or even worse (it's the first time with IMU's).

What is the solution? What is the problem with it? May be burned? May the developing platforms be broken( I doubt)? May...What? I don't know what to do.

And just to know this is the IMU board: https://www.sparkfun.com/products/10121

sbright33

I had a difficult time with the compass and gyros, but I got the Acell working immediately!  Nothing?
If you fall... I'll be there for you!
-Floor

Skype Brighteyes3333
(262) 696-9619

RobertEagle

Nothing is working. I mean I have this IMU for over a year and till now I haven't remove it from it's protection. Might be burned? I didn't give a higher the voltage than 3.3V. I haven't switched a connection. Nothing. I get nothing from serial.

Thank you,
RobertEagle

kriista

You should try just reading the values and sending them to serial.write directly and take a look in the serialmonitor to see what kind of numbers/data you get in.

Trying to use pre-built sketches (particularly complex sensor based things with multiple libraries) it can be difficult to troubleshoot.

I've had similar problems with the i2c sensor in my setup though the ones coming in over analog pins worked fine almost immediately (http://arduino.cc/forum/index.php/topic,117638.0.html).

I'm currently still having a problem with the i2c (magnetometer) as the data I'm receiving on the computer isn't right, so I think something is going funny between the Arduino reading the sensor data over i2c (as two bytes) then combining it into one byte, then me splitting it into two bytes again to send out.

Krodal

That board has two 4k7 pull-up resistors to the 3.3V. So you don't have to add external pull-up resistors.

Connect the 3.3V, GND, SDA, and SCL.
Run the i2c_scanner : http://arduino.cc/playground/Main/I2cScanner
If the i2c_scanner doesn't see any devices on the I2C-bus, the SDA and SCL might have been mixed up. Check the wiring (again).
Can you measure the 3.3V to see if it the board has power.

If everything failes, can you upload a photo to show how you have connected it ?

Go Up