Go Down

Topic: UNO Rev2 "Unknown Device" - Tried 8U2 DFU, still not recognized. [Resolved] (Read 1 time) previous topic - next topic


Platform: Arduino UNO revision 2
OS: Windows 7 64 bit
Error: "Unknown Device"

I've tried following all threads I could find. I looked up the datasheet for the 8U2 and performed the reset for DFU mode. The Arduino resets and is re-detected by Windows, but it still shows as "Unknown Device" where I expected to see the controller name. I pulled out my 328 and no change. The Arduino does not attach to any COM port, so I can't even try to talk to it through any software. I've tried manually assigning both the Arduino and the Atmel drivers, but to no avail.

It was working just fine then I upload some sketch modifications and nothing.

I did notice that LM358D is getting very hot since I've had this error. Not sure how to check and see if there is a problem with that chip or surrounding traces, or how that might upset the USB communications.

I've ordered an ISP programmer, not sure if that will help in this case, but I'm ready to try anything that wise people have to suggest.


Well, nobody replied as I may have suspected. I ended up having to buy a new board. I Got a USBTinyISP programmer and tried accessing both chips on the old board, and neither one of them responded. So I'm guessing something else on the board failed rendering it bad. I don't know if I'm brave enough to risk trying to recover the 328 by putting it in a new board and reprogramming it, so I'll probably write it off as a loss.

So for anyone troubleshooting their chips, the USBTinyISP was super-cheap and gave me a 100% confirmation that I could not access either chip, even through the headers.

Go Up