Go Down

Topic: [Projet] Un tableau de bord numérisé (Read 24 times) previous topic - next topic

Super_Cinci

Pour revenir au sujet de base, j'ai été "obligé" de le rendre un minimum présentable car j'exposais mon embryon de TDB avec un petit speetch à des élèves du lycée. Les copains profs m'ont bien eu, car c'était des élèves de première, donc pas encore à même de piger les notions que j'abordais. Il espéraient en fait que je déclenche quelques réactions, histoire de repérer quelques uns qui auraient déjà du code dans les doigts, mais non, pas dans cette promo. J'y retournerai quand même pour apporter un oeil "extérieur" sur les TPE

Mais les 4 potars que j'ai mis font bien bouger les aiguilles, les compteurs s'incrémentent quand on le leur demande, c'est pas trop mal.

J'ai soudé un petit transistor et codé une PWM pour la gestion du contraste, mais pas encore essayé...

Super_Cinci

#66
Sep 15, 2012, 01:02 pm Last Edit: Sep 15, 2012, 01:41 pm by Super_Cinci Reason: 1
Et j'ai bien fait de ne pas essayer...

Un coup de metrix sur la broche V0 du LCD : -11.2V, là, tout s'est effondré... Puis finalement, j'ai regardé de plus près, le potar qui gère le contraste est connecté entre le +5 et VEE (VEE = -13.5V). Ouf! on peut donc faire un truc simple avec un PNP :



Rien de plus facile au final, car sur le back-pack, il y a deux rangées de trous pour relier un LCD, puisqu'il est prévu aussi bien pour le LCD 160x128 (le mien) que le 128x64. Donc je fais un circuit qui se soudera sur les trous du 128x64 (pour avoir accès aux pins J1 à J4), et un petit câble plat entre J5 et le connecteur ISP pour récupérer le OC2A qui s'y trouve. J'en profite pour rajouter quelques capas (C2 et C3 erreur de frappe, C3 = 330µF) de filtrage, car les alims sont vraiment pas belles à l'oscillo (ça ondule de +/-0.4V alors qu'à la base, je peux fournir jusqu'à 2A...). J'ai aussi constaté que le contraste est très sensible à l'alim, avec un réglage correct sous 5V, il suffit de descendre à 4.7V et tout disparaît.

Le backpack avec ses deux rangées de connecteurs :



Le typon (que j'ai fait avant de dessiner le circuit, c'est ma spécialité...) :



Cet am, je ferai d'autres circuits puis un peu de gravure (tant qu'à utiliser de l'eau oxygénée, autant faire un max de circuits dans le bain qui sera perdu).

Super_Cinci

#67
Sep 16, 2012, 05:56 pm Last Edit: Sep 16, 2012, 07:09 pm by Super_Cinci Reason: 1
Et ça marche :



On voit à droite du connecteur ISP la trace du potar que j'ai dessoudé (j'ai arraché la piste sur l'autre écran...)

Bon, il a fallu que je câble autrement mon transistor, car le contrast se règle sur un petit poil (entre -8 et 12V, en dehors, on ne voit plus rien...).



Reste qu'il va falloir peut-être changer les régulateurs de la carte de sparkfun, car ils ne sont vraiment pas bons. le VCC s'écrase pour un rien, alors que le 5V qui rentre dessus ne bouge pas d'un poil...

J'ai finalement trouvé un compromis pour utiliser le timer 2 à la fois pour le clignotement des icônes et pour la PWM du contraste, reste à tester (avec le timer 0, ça clignote pas du tout...)

Super_Cinci

Un peu d'avancement...

J'ai fait les connecteurs pour brancher le faisceau d'origine et câblé les voyants...



C'est sûr que le tableau de bord d'origine fait plus propre, mais m'en fous, ça se verra pas...



Reste un dernier connecteur à faire qui ira vers l'unité de traitement et normalement, de ce côté, c'est fini (à part certainement encore un peu de prog rectificative sur les écrans...)

fdufnews

En vibration, un condensateur radial n'est pas très endurant. Personnellement, je mettrais un point de colle sur les capa pour éviter de les retrouver au fond du tableau de bord dans 1 an.

Go Up