Go Down

Topic: Probleme librairie (Read 1 time) previous topic - next topic

darknessoff

Bonsoir,

Je suis entrain de réaliser un projet, la partie hard est bonne, le soft ne pose pas de problème sauf que je coince juste avec les librairies.

j'utilise celle ci :

Code: [Select]

#include <Keypad.h>
#include <stdio.h>
#include <EEPROM.h>
#include <avr/interrupt.h>
#include <avr/io.h>
#include <avr/sleep.h>


le Keypad.h et EEPROM.h sont orange signe que les librairies sont bien installé mais par contre impossible de trouvé les autres.
j'ai bien trouvé les fichiers *.h mais il manque les autre fichier qui constitue la librairie comme les *.cpp ou les keywords.

j'ai bien chercher sur internet mais pas trouvé comment les installées. =(

Est ce que quelqu'un a les librairies ou une solution pour les trouvé ou même résolut le souci ?

Merci par avance.
--Darknessoff--

SesechXP

Salut,

Malgré le fait que les noms des bibliothèques ne se colorent pas, la compilation réussit-elle ? Peut-être que c'est juste la coloration syntaxique qui ne prend pas en charge les bibliothèques d'avr-gcc... Si tu ne trouves pas les fichiers cpp de ces bibliothèques, c'est parce qu'elles sont déjà compilées et contenues dans des fichiers *.a situés dans le répertoire d'avr-gcc.

++
Julien - www.idreammicro.com

fdufnews

Les librairies dont tu parles sont les librairies standard  et elles sont donc installées en même temps que la chaine de compilation

skywodd

Bonjour,

Même réponse que SesechXP et fdufnews, ce sont des librairies AVR-GCC de base inclut dans la avr-libc ;)

Les détails de chaque fichiers :
http://www.nongnu.org/avr-libc/user-manual/group__avr__stdio.html
http://www.nongnu.org/avr-libc/user-manual/group__avr__interrupts.html
http://www.nongnu.org/avr-libc/user-manual/group__avr__io.html
http://www.nongnu.org/avr-libc/user-manual/group__avr__sleep.html
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

darknessoff

oui, la compilation est correcte et même l'upload sur la carte.
Et je me demander ce matin si par hasard ce ne serai pas le chemin simplement qui ne serai pas bon pour qu'il trouve la librairie ?
--Darknessoff--

fdufnews

Quote
oui, la compilation est correcte et même l'upload sur la carte.

Mais alors où est le problème? Je comprends pas.

SesechXP

Seulement la coloration syntaxique qui ne fonctionne pas avec l'IDE Arduino ;)

A part en modifiant l'IDE Arduino pour qu'il indexe la bibliothèque standard et colore les mots-clés, je ne vois pas de solution...
Julien - www.idreammicro.com

fdufnews

La coloration syntaxique fonctionne pour les librairies additionnelles lorsqu'elles sont accompagnées, dans le répertoire où elle sont déclarées, du fichier keyword.txt.

Pour les mots-clés du langages il y a un fichier keyword.txt qui se trouve:
    pour linux, dans usr/share/arduino/lib
    pour windows, arduino/lib (ou quelque chose comme ça je n'ai pas de conf windows sous la main à l'instant)
Il est possible d'ajouter des mots clés dans ce fichier mais il sera écrasé à chaque mise à jour.

SesechXP

Tout à fait, je sais bien qu'il y a ce fichier keywords.txt mais ça ne me semble pas forcément le plus adapté aux bibliothèques standards d'avr-gcc... Et semble plutôt destiné aux membres Arduino. D'ailleurs tu le dis bien, il sera écrasé à chaque mise à jour :(

Je rêvais juste à un indexeur sauce Eclipse :smiley-mr-green:
Julien - www.idreammicro.com

darknessoff

oui, pour la coloration je l'ai bien compris et vu. mais ce qui m'embêtait c'est que le programme ne réagis pas comme il devrai. je me demander donc si cette librairie n'etait pas en cause. je suis entrain de reprendre toute la prog, je vais bien voir si cela viens de ca  :)
Merci encore a tous pour toute ces précisions sur cette librairie, je donnerai des nouvelles une fois le problème trouvé
--Darknessoff--

Go Up