Go Down

Topic: Bootloading SMD ATMega (Read 3019 times) previous topic - next topic


I have an Arduino Duemilanove that I can program using the USB cable and Windows 7. I have had no problem working with it.
Now I want to use it to program a blank ATMega328pAU (SMD) that I have on a board.

I took the design from the Arduino Nano schematic. the JP1 is a connection for the FTDI and JP2 is an ICSP connector.
I have tried the Arduino on a breadboard (http://arduino.cc/en/Tutorial/ArduinoToBreadboard) tutorial. The first part works flawless (when you upload the scketch to your Duemilanove). The second part though is where I get this message:

I have tried selecting Nano, Duemilanove and others whith a 328. I even tried the minimal circuit thinking that maybe the crystal is not working properly.
Anyone have any idea why it is not working? I think I may try the USBtinyISP but I want to try everything before going that way. I have checked the connections many times but I keep getting the same message.
Thanks in advance

Tom Carpenter

You will need to connect pin 6 of the FTDI header to the reset pin of the atmega with a capacitor of approx 100nF. That will enable the autoreset feature.
Alternatively you need to press the reset button just as the IDE finishes compiling.


Thanks for the reply!
Now I have good news and bad new.
Good news: I was able to bootload the ATMega, for some reason (probably the 16 MHz crystal is not working properly, or at all) it worked when I used the minimal circuit on the tutorial. Even better, then I connected the FDTI to the board (5V, GND, TX and RX) through a breadboard and uploaded the blink (on pin 13) example. At this point I disconnected everything to see if it had uploaded correctly, and it did.
Bad new: I connected everything again to upload another example (lets say change the pin or the delay) and I cannot get it done. I keep getting avrdude: skt500_getsync(): not in sync: resp=0x00. I even removed the ATMega from the Duemilanove to use it FTDI chip, but nothing. If I power my board alone it keeps blinking on port 13, so it is still working.
I know there are many reasons to get this message. I've tried pressing reset before it starts the uploading... but nothing.
Again, thanks in advance.

Tom Carpenter

It suggests that you have connected something up wrong when you reconnected it. Double check all of your connections (especially the RX line of the FTDI board)

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131