Go Down

Topic: Arduino Mega2560 stopped being detected in Windows XP (Read 587 times) previous topic - next topic

socjcare

When I first got the Mega2560 that I recently bought online ( I think I've got the Rev 2),  and connected it to the PC, it worked right away. I used the Arduino IDE and was able to upload sketches.  Then after a few days ,  it stopped being detected by Windows. There is no more COM Port in Device Manager, so I could not connect to it with the Arduino IDE.

I thought maybe, the USB-to-Serial conversion being handled by  the Atmega8u2 was damaged. So thinking maybe the firmware for the USB-to-serial was corrupted, I decided to program the Atmega8U2 with my AVR Dragon and AVR Studio 4.1.

I used the ISP header beside the Atmega8u2  a nd connected it to the AVR Dragon programmer, to program the firmware on the 8u2.  I programmed Arduino-usbserial-mega.hex that I found in ...\arduino-1.0.2\hardware\arduino\firmwares\atmegaxxu2\arduino-usbserial  ,  then powered down the board, powered it back up and then connected the USB cable to the Mega. Still, it was not detected, as if nothing was plugged to the USB port. I even tried several times to reboot the PC, but no change was seen.

Next thought was maybe the bootloader on the MEGA 2560 was corrupted, so this time I connected the Dragon to the ISP connector for the Mega2560.

I used the stk500boot_v2_mega2560.hex in ..\arduino-1.0.2\hardware\arduino\bootloaders\stk500v2. As far as I could tell, this also worked fine, as AVR studio prompted me that programming was OK. I also followed the instructions with regards to the fuse and lock settings. I know that the mega2560 is still alive, because I uploaded the hex file for the 'blink" sketch compiled in Arduino IDE and could see the LED blink as it should.

Still, I could not get the COM port to work.

I am thinking now to replace the Atmega 8U2 with a new chip, or simply, disconnect it,  get a USB-to-serial adapter and then connect it to the TX0 and RX0 pin. I am not sure though if I need to connect some other pins. I 've read if I using the Atmega8u2,  the DTR pin has to be attached to the RESET pin so that uploading of sketches would work  without the need to press the RESET button.

Any help or ideas to try or something that I did wrong would be greatly appreciated. Can someone please tell me if I used the correct firmware for the usb-to-serial in the atmega8u2 and the bootloader in the atmega2560?


Go Up