Go Down

Topic: Arduino ecriture base Access ou SQL (Read 6 times) previous topic - next topic

PITP2

toujours rien .... malédiction sur mon arduino     :~

cbrandt

et avec un mac (ou pc…), dans le terminal en tapant
Code: [Select]

telnet google.com 80


tu obtiens quelque chose ? sur le mac il devrait afficher quelque chose comme

Code: [Select]

Trying 173.194.34.100...
Connected to google.com.
Escape character is '^]'.


puis tu tapes

Code: [Select]

GET /search?q=arduino HTTP/1.0



donc la ligne GET etc en terminant par entrée puis une deuxième fois entrée…
là devrait apparaître la réponse du serveur:

Code: [Select]


HTTP/1.0 200 OK
Date: Sun, 26 Aug 2012 20:11:25 GMT
Expires: -1
Cache-Control: private, max-age=0
Content-Type: text/html; charset=ISO-8859-1





skywodd

Question bête mais qui (je crois) n'as pas était posé :
Sous quelle version de l'ide travaille tu (>=0023 ou <=1.0) ?
C'est peut être un probléme de configuration (logicielle et/ou matérielle).

Essaye l'exemple TelnetClient : http://arduino.cc/en/Tutorial/TelnetClient
Avec l'ip de ton pc comme cible et une console netcat en écoute (nc -l -p 10002).
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

cbrandt

avec l'adresse 173.194.34.68 pour google, ça marche chez moi… (juste adapté le sketch pour l'ide 23 sur un mega2560)

PITP2

pour l'ide je crois que je suis en 1.0.1 c'est possible ?

j'ai essayé la méthode exposée en telnet mais cela ne donne rien chez moi ...
je suis sur PC alors la méthode change un peu je crois ?

Go Up