Pages: 1 ... 3 4 [5]   Go Down
Author Topic: Domanda su Pachube/Cosm  (Read 2761 times)
0 Members and 1 Guest are viewing this topic.
Selvazzano Dentro - Padova
Offline Offline
God Member
*****
Karma: 28
Posts: 932
"Chi sa fa, chi non sa insegna"
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Agiamo su due fronti: facciamo anche un'altro tentativo con gli amplificatori.

Aumentiamo l'amplificazione portando ARef da 3.3V a 5V: sostituisci i resistori  di retroazione da 240k a 360k e tara i tre circuiti per misurare non 3.3V, ma 5V. Ricordati che l'alimentatore deve essere stabilizzato da almeno 9V.

Probabilmente troverai ancora una componente continua che rompe le scatole (dovrebbe essere sui 100mV) dovuta agli operazionali.

Misurala con precisione.

Nel software poni:
CosFi = 1 (carico puramente resistivo)
analogReference(EXTERNAL);                      // pin AREF connesso a pin +5V (non +3.3V !!!!)
int CicliMax = 1000;                              // ogni ciclo dura da 500 us a 1 ms (eventualmente provare anche 2000 !!)

Postami i risultati.

Ciao!
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buongiorno Massimo,
ecco i risultati dopo la Modifica con un resistore da 360KOhm.

Al massimo, con una entrata di 1.41Vp, all'uscita ho un valore Vpmin di -80mV
Al minimo, con una entrata di 110mVp, all,uscita ho un valore Vpmin di -8mV

Allegate le foto delle misure effettuate con l'oscilloscopio.

P.S. il valore dei 5Volt è tarato, ma nell'oscilloscopio salta fra 4.96 e 5.04.


Ulteriore domanda, ho bisogno ancora dell'Aref External ?
Se l'arduino di Default usa gia il range 5 volt ?

Le prove con Arduino potro farle al pomeriggio....



Saluti
Remo


* In 1_41Vp__Out_4_96_Vp (Large).jpg (181.21 KB, 1024x768 - viewed 4 times.)

* In_110mV_Out_440mV (Large).jpg (178.43 KB, 1024x768 - viewed 3 times.)
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok, collegato un attimo.
Aref collegato sul pin 5 V

Wattcher = 800watt

Arduino = 0 :-(

Riprovero al pomeriggio

Saluti

Remo
Logged

Selvazzano Dentro - Padova
Offline Offline
God Member
*****
Karma: 28
Posts: 932
"Chi sa fa, chi non sa insegna"
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Problema dell'offset.

L'entrata sommante degli operazionali è attualmente a massa; per ridurre l'offset, bisogna, invece, inserire su di essa un resistore di valore pari a quello del parallelo del resistore di ingresso (R1) e quello di retroazione (R2) cioé 78k (collegato a massa).

Però assicurati prima che la componente continua non sia prodotta da tuo generatore!

Problema software.

Mi raccomando di modificare i valori di CosFi, analogReference, CicliMax come indicato e di collegare il riferimenti AREF ai +5V (poi aggiusteremo questa cosa eventualmente).

Per CicliMax prova ad modificare il valore (500, 1000, 1500, 2000, 3000)

Se lo hai fatto, non mi spiego questo risultato: non puoi inserire un carico resistivo certo di prova?

Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Scusa Massimo,
Nn ho capito dove di preciso collegare la resistenza da 78 kohm..

Saluti
Remo
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah ci sono arrivato da solo...
Intendi sul + di ogni amplificatore...
Sai che faccio? Ci metto un trimmer da 100 k e cerco di regolare lo 0 perfetto

Saluti
Remo
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Con i trimmer nn cè possibilità di regolare l'offset.

Alla fine mi sono accorto che l'offset è dato dalla tolleranza dell'oscilloscopio !!!

Nn riesco a spiegarmi perche, se scelgo una scala da 2 V l'offset mi viene mostrato a -80 mV
Se scelgo 1 Volt viene mostrato -40 mV
Se scelgo 200mv viene mostrato -4 mV di offset.....

percio nn ha a che vedere con l'arduino.....

Scusami...tolgo i trimmer e rimetto i + degli Opam a massa....

Ciao

Remo
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No way :-(

situazione invariata....

Caro Massimo non voglio approfittare della tua disponibilità !!

Ti ringrazio tantissimo.

Domani riprendero in considerazione il fatto del partitore che setta lo "0" a 1.65V e da li l'onda del sensore potrà oscillare in tutta tranquillità fra + e -.
Bisognerà solo poter captare il max e min delle sinus.
Lo avevo già in funzione ma mi mancava lo sketch esatto, o meglio detto la formula esatta.

Dai godiamoci questa Inter-Roma....da domani ricontrollerò e riproverò .

Grazie Massimo e buona serata

Remo
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buongiorno Massimo.
Questa sera ho intenzione di montare un partitore di 1.28V (1 x tutte e 3 le sonde) sul mille fori. Prendendo l’alimentazione die 5V di Arduino.

Settare L’Aref interno dell’arduino a 2.56V.

Dopodiche prendero una lampadina da 100w come referenza e cominceró a costruire il tutto da questo punto.

1,28V equivalgono a circa 26A (Valore che non raggiungeró mai a casa mia), penso che possa bastare, in compenso avró una risoluzione minima di 2.5 mV.

Dimmi se ho scritto una grande cavolata  smiley-eek

Saluti e buon inizio di giornata.
Remo
Logged

Selvazzano Dentro - Padova
Offline Offline
God Member
*****
Karma: 28
Posts: 932
"Chi sa fa, chi non sa insegna"
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ma hai una MEGA oppure una UNO?

Con UNO puoi settare valori interni di analogReference a DEFAULT (5V), INTERNAL (1.1V), EXTERNAL (0-5V)

Con la MEGA DEFAULT (5V), INTERNAL1V1 (1.1V), INTERNAL2V56 (2.56V), EXTERNAL (0-5V)

Proprio perché la tensione varia tra -1.41 e +1.41 si è preferito EXTERNAL con il collegamento ai 3.3V.

La domanda è: cosa succede ad Arduino se all'ingresso analogico invio una tensione negativa? Mi sembra di aver letto che non è consentito, se non entro certi limiti, ma no riesco a trovare dove.
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho un Mega,

infatti, tensioni negative fanno male all'arduino.

è per questo che vorrei dare l'offset "0" pari a 1,28.

+1.28
-1.28

Arrivo a circa 26-27 Ampere ,cosa che in casa non sarà mai possibile.

Saluti
Remo
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Correggimi se sbaglio.

Prenderei l'alimentazione 5 V da arduino.

Con due Resistenze R1= 58K R2= 20K avrei un'uscita 1.28Volt, questo sarà il mio Offset.

Cosi il sensore potrà oscillare per un totale di 2.56Vpp (restando sempre nel Range positivo dell'arduino).

domanda : l'alimentazione dell'Arduino (5V) riesce a gestire un solo partitore per tutte e 3 le sonde ?

Saluti e buon appetito

Remo
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao Massimo,
alla fine ho provato con il partitore da 1,28 Volt e un Aref interno di 2,56.
Non riesco a sfruttare tutto il range di 30 Ampere, ma fa niente, arrivo fino a 27,3 Ampere ed è piu che sufficiente.

L'alimentazione per il partitore lo prendo a parte (i 5 Volt di Arduino erano instabili).

Al momento cè da lavorare ancora sullo sketch (differenze di circa 100-200w) ma penso di essere sulla buona strada.

Voglio ringrazioarti ufficialmente per tutte le dritte, schemi e consigli che mi hai dato !!

GRAZIEEEE !!!

Penso che con questo posso chiudere il Topic.

Un saluto e buon pomeriggio
Remo
Logged

Pages: 1 ... 3 4 [5]   Go Up
Jump to: