Pages: 1 2 [3]   Go Down
Author Topic: Ejemplo Webclient no funciona y envio de email sin PC [SOLUCIONADO]  (Read 5249 times)
0 Members and 1 Guest are viewing this topic.
Entre Bits
Offline Offline
Full Member
***
Karma: 2
Posts: 119
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si copias y pegas tu direccion http://www.dominio_que_has_creado.net84.net/nombre_fichero.php?para=email_destino@hotmail.es dices que te funciona?? si es asi queda claro que el dominio esta bien creado al igual que el fichero PHP, con lo que nos queda el Arduino que debe ser donde esta el problema ahora ya o pones el programa para pegarle un vistazo o poco voy a poder ayudar ya que segun dices el sketch es el webclient modificando solo esa parte, siendo cierto yo lo tengo igual y me funciona.


EDITO: Acabo de revisar mi programa y creo que he visto donde puede estar tu problema, ¿Has puesto en IP Addres la direccion IP del servidor WEB o has dejado la de google??? si no has tocado nada es logico que no te funcione, has de cambiar la ip por:

IPAddress server(xx,xxx,xxx,xx); // IP HOSTING

Esta IP la verás aqui:



Si habias dejado la de google era logico que no funcionara, quiere conectar con el servidor google y luego le dices parametros de un servidor que no es el suyo  smiley-wink



Recuerda que para hacer pruebas no envies muchos mails seguidos (creo que eran 18 en menos de un minuto) ya que el servidor te bloqueará la cuenta porque pensará que es un envío masivo de emails y por seguridad anti SPAM te cerrará la cuenta.
« Last Edit: March 20, 2013, 01:02:51 am by Dystrom » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Efectívamente, lo que dices se acera mucho a lo que hacía. Lo que yo hacía era poner toda la dirección URL de mi servidor junto con mi archivo php y los parámetros, dentro del espacio de "char serverName []" en el ejemplo de DNSwebclient. smiley smiley

Gracias a que tu me dijiste en el pasado post lo que tu hacías, casi cuenta de mi error, porque yo no tomaba en cuenta la linea de "client.println(GET" donde pones la dirección URL, y por ende la dejaba igual.

Ya hice los cambios necesarios especificando todos los parámetros en la linea de "client.print(GET"........ y ¡¡¡¡¡¡¡¡¡YA FUNCIONÓ¡¡¡¡¡¡¡

Ahora le voy a quitar todo lo que sea serial para dejar el programa sin que tenga que usar la computadora


Gracias por tu ayuda compañero Dystrom, me fue bastante útil para hechar andar esta función smiley
Logged

Entre Bits
Offline Offline
Full Member
***
Karma: 2
Posts: 119
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Me alegro de que ya te funcione, aunque tus agradecimientos los compartiré con los compañeros que en su día me ayudaron a aprender todo esto a mi (Sergegsx y PepeChorva) asi que tocamos a un 33,33333333...% cada uno  smiley-razz
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Tengo una duda con eso de mandar un parámetro a una página web a través de Arduino.
También estoy haciendo algo similar al enviar un correo y estoy usando el sketch de ejemplo del wifi shield, pero no se que tengo que poner en las siguientes líneas:

char server[] = "www.google.com";    // name address for Google (using DNS)
client.println("GET /search?q=arduino HTTP/1.1");
client.println("Host: www.google.com");
client.println("Connection: close");    // Esta última línea no se muy bien que hace

Ya tengo un servidor online, tengo un dominio y tengo el código php con el cual recibiré los parámetros. Pero lo eh ejecutado sustituyendo en char server el nombre de mi dominio, en GET la url donde esta mi código php, pero no consigo que se envie el correo.
¿Alguna idea?
Logged

0
Offline Offline
Edison Member
*
Karma: 17
Posts: 1407
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

es dificil ayudarte con los datos que das
Logged

* Si preguntas, pon el código de tu programa, hace mucho mas fácil ayudarte. Y me ahorro un mensaje pidiendo que lo hagas.
* Si consigues solucionar tu problema, dedica unos minutos a explicar en tu post como lo conseguiste para beneficio de todos.
* Cambia el 'Subject' de tu hilo y añade 'SOLUCIONADO' cuando hayas llegado a una solución al problema que planteaste.
* Utiliza un 'Subject' para tu hilo que explique de que va el hilo.
Si estas empezando:
* Comienza a usar Arduino
* Guías de iniciación a Arduino
* Ejemplos
* Referencia del Lenguaje
* Conceptos básicos
Guia de usuario de arduino
Tutoriales en Ingles
Si necesitas que alguien te escriba el código: http://www.freelancer.com/  o esta  http://www.guru.com/

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Estoy utilizando este código (es parte del sketch webclient):

Code:
#include <SPI.h>
#include <WiFi.h>

char ssid[] = "red";
char pass[] = "pas";
int keyIndex = 0;
int status = WL_IDLE_STATUS;
char server[] = "www.midominio.com";
WiFiClient client;

void setup() {

  Serial.begin(9600);
 
  if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi shield not present");
    while(true);
  }
 
  while (status != WL_CONNECTED) {
    Serial.print("Attempting to connect to SSID: ");
    Serial.println(ssid);
    status = WiFi.begin(ssid, keyIndex, pass);
    delay(10000);
  }
  Serial.println("Connected to wifi");
 
  Serial.println("\nStarting connection to server...");
 
  if (client.connect(server,80)) {
   
    Serial.println("connected to server");
    client.println("GET /archivo.php HTTP/1.1");
    client.println("Host: www.midominio.com");
    client.println("Connection: close");
    client.println();
   
  } else {
    Serial.println("No se pudo conectar al servidor");
  }
}

void loop() {

  while (client.available()) {
    char c = client.read();
    Serial.write(c);
  }

  if (!client.connected()) {
    Serial.println();
    Serial.println("disconnecting from server.");
    client.stop();

    while(true);
  }
}

Mi problema es con esta línea if (client.connect(server,80)), ya que no me conecta con el servidor por lo que no puedo mandar los parámetros con el GET.
Los que se ejecuta es
Starting connection to server...
No se pudo conectar al servidor

Alguna idea de que pueda estar pasando y que pueda hacer para corregirlo.
Logged

Pages: 1 2 [3]   Go Up
Jump to: