Pages: [1]   Go Down
Author Topic: COM 6 not found  (Read 1654 times)
0 Members and 1 Guest are viewing this topic.
Bristol, UK
Offline Offline
Full Member
***
Karma: 1
Posts: 125
part time tinkerer
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,

i get an irritating issue with my arduino uno, connected via usb.

whenever i run a sketch that uses the serial monitor to view the outcome, i can program the arduino once, but then i get COM6 not found error the next time i try.

changing usb ports doesn't free it up, and the only way i can find to solve it it to reboot the machine.

the full error
Code:
processing.app.SerialNotFoundException: Serial port 'COM6' not found. Did you select the right one from the Tools > Serial Port menu?
at processing.app.Serial.<init>(Serial.java:191)
at processing.app.Serial.<init>(Serial.java:77)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:77)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:172)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)
at processing.app.Sketch.upload(Sketch.java:1706)
at processing.app.Sketch.exportApplet(Sketch.java:1662)
at processing.app.Sketch.exportApplet(Sketch.java:1634)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2346)
at java.lang.Thread.run(Thread.java:619)
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you test this and say me if problem continues? http://arduino.cc/forum/index.php/topic,118440.0.html

I have replaced the winavr version, I was suspecting that was the error with serial ports
Logged

My website: http://ried.cl

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have same issue. ERW 1.0.3 does not solve the problem still get error after 1 upload. Does anyone know how to fix this.
ERW 1.0.3 does not even give the auto fix option that says it's supposed to have.  smiley-confuse
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

/bump
no one on the internet has solved this or figured why it happens to some people

Logged

Offline Offline
Jr. Member
**
Karma: 1
Posts: 69
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Change the COM port in device manager via system via control panel
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Change the COM port in device manager via system via control panel
Tried, does not work.  smiley-sad
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

/bump
(for 3 weeks no replies no solution posted)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was having the same issue and I fixed it by moving the usb to a different port
Logged

Pages: [1]   Go Up
Jump to: