Pages: [1] 2   Go Down
Author Topic: Arduino UNO R3 Help Please  (Read 1000 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This is what happened. I received my Arduino Uno R3 in the mail. I followed the instructions perfectly and successfully loaded the blink sketch. I then installed the Parallax PIR Sensor and downloaded a sketch for it and it worked great! I got tired of it after a while and reconnected to my Windows 7 X64 as usual, and it just kept playing the connection noise over and over again. You know the one that you hear when you plug anything into a USB port. They are USB 2.0's if you're wondering. In the device manager the Com Ports have disappeared. I have system restored, cleaned my registry and junk files. Re-downloaded the IDE 1.0.1 and the older 1.0. Nothing works at all. I am very frustrated and can't seem to find anyone that has had the same problem. Also I have changed USB connector cords and I have tried another PC with the same Windows 7 X64. I could not update the drivers on the other PC it said they were up to date. I uninstalled and re-installed but no luck. Can anyone help please?
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6146
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

With nothing connected to the Arduino board, it does not appear as a COM port anymore?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the reply. I have tried connecting the arduino without and with things connected to it. No com port is found.
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6146
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Does the power LED turn on and then fade out?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Lights that turn on and stay on are the ON light (green) and the Pin 13 light (amber).
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6146
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

In the device manager the Com Ports have disappeared.
Okay... but then you said:

I could not update the drivers on the other PC it said they were up to date.
So if the com ports are not in device manager, how are you able to check the driver version?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here is what the arduino looks like when it is plugged up to my USB port.


* 2012-09-01 18.58.43.jpg (2476.94 KB, 3264x2448 - viewed 13 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

On my computer the com 3 port was there when everything was running smoothly. When it wouldn't connect the com 3 port disappeared. On the other computer I started the normal setup. I saw the device in the device manager but when I tried to update it it said the drivers were up to date and it stayed with a yellow triangle.
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

On my computer the com 3 port was there when everything was running smoothly. When it wouldn't connect the com 3 port disappeared. On the other computer I started the normal setup. I saw the device in the device manager but when I tried to update it it said the drivers were up to date and it stayed with a yellow triangle.

You need to install the correct inf file. I worked on an automatic driver installer but I am not sure if it fixes current non working devices (I am using an official toolkit from microsoft to install drivers). http://arduino.cc/forum/index.php/topic,118440.msg891474.html <- select the board you own when asked.

 If you test it and works for you please post it here so I can know it fixes those kind of problem. If no, maybe I can work to troubleshoot this kind of issues in an automated way smiley
Logged

My website: http://ried.cl

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you. I'm downloading it now. I will post after it fixes it or not.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I installed the program and the drivers for the UNO R3. However, when I plug the arduino into my pc it still constantly replays the connected tone over and over again and does nothing. I can't find anything in the device manager either.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here is the error. It doesn't really help seeing how my pc doesn't recognize the arduino. But I thought you would like to see it anyways.


* 2012-09-01 19.30.41.jpg (3395.43 KB, 3264x2448 - viewed 16 times.)
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Here is the error. It doesn't really help seeing how my pc doesn't recognize the arduino. But I thought you would like to see it anyways.

Not really, it is something I screwed in the last version with new WinAVR, I will try to fix that soon, but can you point the Device manager to install "C:\Program Files (x86)\Arduino\Arduino ERW 1.0.1b\drivers\Arduino UNO REV3.inf" this driver? or the one from your other arduino ide folder?
Logged

My website: http://ried.cl

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

In the device manager there is not anything there resembling arduino uno or an object that has a yellow triangle like usual. So there is nothing I can point to it. When the usb connecting tone sounds over and over the device manager flickers but does not give me anything that I can point to those drivers.
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

In the device manager there is not anything there resembling arduino uno or an object that has a yellow triangle like usual. So there is nothing I can point to it. When the usb connecting tone sounds over and over the device manager flickers but does not give me anything that I can point to those drivers.

I see, so the most probable thing is the 8u2 is dead or not properly configured. Search for instructions to set it in DFU mode to see if is alive smiley-grin
Logged

My website: http://ried.cl

Pages: [1] 2   Go Up
Jump to: