Go Down

Topic: Can't upload to Arduino Mega 2560 (Read 5 times) previous topic - next topic

Samueldw

Since yesterday, I can no longer connect to my arduino Mega 2560. I was playing with a servo when the servo had some strange behavior (turning left, right, right, left etc etc). After that, I can't upload anything to my Arduino. I'm running Windows 7 and I had never problems before.

When I try to upload something to the board with the shift key enabled, I get the message 'avrdude: stk500_getsync(): not in sync: resp=0x00'.
I tried to burn the bootloader through usb but that gives me the same error.

In the Arduino environment are the board type and the port entered correctly.

I hope someone can help me with this.
Thanks in advance.

SurferTim

#1
Sep 02, 2012, 01:59 pm Last Edit: Sep 02, 2012, 02:27 pm by SurferTim Reason: 1
How are you powering the 2560? USB or power jack? Do you still have 5v on the +5v pin?
How are you powering the servo?

edit: Before you think about powering the Uno or Mega with the +5v pin, you should read this topic
http://arduino.cc/forum/index.php/topic,82046.0.html
and this response from the Arduino crew
http://arduino.cc/forum/index.php/topic,82046.msg758170.html#msg758170

Samueldw

#2
Sep 02, 2012, 04:44 pm Last Edit: Sep 02, 2012, 04:53 pm by Samueldw Reason: 1
The 2560 gets its power from an usb port. There is 5.00V on the +5V pin en 3.29V on the +3.3V pin.
I was powering the servo from the +5V, ground and digital pin 9.

I can not really measure the power on pin 9 cause I only have a multimeter and not a scope (I was sending pulses to pin 9 with 9ms interval). Although I can measure that pin 9 is powered.

When I power the servo with an external power supply my program works. So the arduino is still alive.

SurferTim

Do not power the servo from the +5v pin. Bad idea. It is not as much the current, but the inductive nature of servos cause some bad sags and spikes on the power input.

Samueldw

Ok, I will take that into account, but what could cause the problem that i can't upload a sketch or the bootloader?

Go Up