Go Down

Topic: Arduino 13 and BlinkM (Read 563 times) previous topic - next topic

worldgnat

Mar 04, 2009, 08:14 pm Last Edit: Mar 04, 2009, 08:15 pm by worldgnat Reason: 1
I'm trying to use Todbot's BlinkM_funcs.h library to control a BlinkM (normally a simple task), with Arduino IDE v13 on Ubuntu 64. The problem is that when I compile the code, I get these errors:


Code: [Select]

hardware/libraries/Blinkm/BlinkM_funcs.h:35: error: expected ',' or '...' before numeric constant

hardware/libraries/Blinkm/BlinkM_funcs.h: In function 'void BlinkM_beginWithPower()':

hardware/libraries/Blinkm/BlinkM_funcs.h:35: error: too many arguments to function 'void BlinkM_beginWithPowerPins(byte)'

hardware/libraries/Blinkm/BlinkM_funcs.h:48: error: at this point in file

In function 'void setup()':


I've checked through BlinkM_funcs.h and none of the errors seem to make any sense. I downloaded BlinkM_funcs.h again, replaced the file in hardare/libraries, and that didn't do anything. Not only that, but when I compile the exact same code with the exact same BlinkM_funcs.h in IDE v11, it compiles without any errors. Ordinarily I would just use IDE v11, but I'd really like to use the ATMega328.

The blink sketch does compile and upload successfully, so it can compile something, at least.

I'm completely confused by this. Any suggestions?

-Peter

Go Up