Pages: [1]   Go Down
Author Topic: IDE bug - window won't take keyboard focus  (Read 907 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, All -

I've got a strange question...

I just tried to go back and work on a project after a long absence, and for some reason the Arduino IDE will no longer let me type within it.

I can pull up files and open them just fine, can highlight text within the file, but can't enter any text in the IDE interface. It refuses to take focus from my keyboard. (I've tried cutting and pasting text, but can't get that to work either).

The IDE used to work just fine, so I'm not sure what I could have changed on my computer to cause this. Seems to happen no matter what version of the software I'm using.

I found a similar problem in the forums (below), but it was happening in Linux. I'm using a 2011
MacBook Pro running OSX 10.6.8.

http://arduino.cc/forum/index.php?topic=61839.0

Seems like maybe a Java problem, but I can't figure it out - tried updating my Mac's java to no avail.

Has anyone run into this?

thanks,
David L
Logged

Offline Offline
Edison Member
*
Karma: 17
Posts: 1041
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you getting the same error message as the guy in the other thread?

If not, you've probably set "use external editor" in the preferences dialog.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

*FOREHEAD SMACK*
 
Thanks, WizenedEE  - I completely forgot to check that. It's working fine now.

-David
Logged

Pages: [1]   Go Up
Jump to: