Go Down

Topic: atmega1284p/pu (Read 6 times) previous topic - next topic

miros

He guys,
i bought atmega1284pu and i tried to boot bootloader but it didnt work. i was following these tutorials:
http://maniacbug.wordpress.com/2011/11/27/arduino-on-atmega1284p-4/
http://wiki.wiring.co/wiki/Creating_your_own_Wiring_board_with_a_DIP_atmega1284p_using_Duemilanove
I used arduino uno as isp but i get this error:
avrdude: Device signature = 0x1e9706
avrdude: Expected signature for ATMEGA1284P is 1E 97 05
         Double check chip, or use -F to override this check.
Do you think the problem is that i have atmega1284pu and not atmega1284p?
thanks for your answers  :).

johnwasser

If I understand correctly, PU means "plastic DIP package" and P means "pico-power".  The non-Pico-Power chip should be compatible with the Pico-Power version so all you should have to do is change the chip type in the boards.txt file to remove the 'p'. Then avrdude will be happy with the signature.
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

miros

i understand what you mean but i dont know what to change.

CrossRoads

1284-PU has signature bytes    0x1E 0x97 0x06
1284P-PU has signature bytes  0x1E 0x97 0x05

Find your copy of avrdude.conf, and copy the '1284P section, excerpted here:
Code: [Select]

#------------------------------------------------------------
# ATmega1284P
#------------------------------------------------------------

# similar to ATmega164p

part
    id               = "m1284p";
    desc             = "ATMEGA1284P";
    has_jtag         = yes;
    stk500_devcode   = 0x82; # no STK500v1 support, use the ATmega16 one
    avr910_devcode   = 0x74;
    signature        = 0x1e 0x97 0x05;
    pagel            = 0xd7;
    bs2              = 0xa0;
    chip_erase_delay = 9000;

and edit it to take out the P from 1284P and change the signature bytes.

Then, do the same in boards.txt for 1284 vs 1284P.
Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

miros

thanks, i tried but when i changed avrdude.conf i get this error on arduino IDE:

syntax error at
H:\Saved Documents\Mirko\arduino\arduino-1.0\hardware/tools/avr/etc/avrdude.conf:16934

i get this error when i change it and even when i dont. can anyone help?

Go Up