Pages: [1]   Go Down
Author Topic: SD wireless shield. Arduino UNO. Xbee XB24-ZB (API) Firmware (Solved)  (Read 193 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have been playing around with the AT firmware mode and it works great.

However i decided to try out the API mode.

I am using XCTU and a wireless SD shield. After upgrading firmware to API mode i am unable to connect using XCTU.

One thing that i did notice was that the firmware put me into a cyclic sleep mode. I had only done the API mode to the end device and now i am unable to make any changes to the xbee module. I have been searching everywhere and it seems that everywhere tells me to get either an xbee xplorer from sparkfun (https://www.sparkfun.com/products/8687) or an XBIB (http://www.digikey.ca/product-search/en/rf-if-and-rfid/rf-accessories/3539661?k=XBIB) in order to properly communicate with the module again.

Am i doing something wrong?  
 
Baud rate 9600, everything is exactly the same except the new firmware API i put in there.

I did find this information - http://www.digi.com/support/kbase/kbaseresultdetl?id=3402#ZigBee
in order to reset to AT mode i have to either get the Xbee explorer or the XBIB. Does anyone know how i can properly use xctu with the Wireless SD shield from arduino?

I appreciate any feedback!! Please let me know!


« Last Edit: February 05, 2014, 04:14:32 pm by adelima » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Solved this issue...

If you are using API mode, you will have a hell of a time trying to alter Xbee settings if you do not get XBIB or Xbee Explorer.

I got the XBIB R and i was allowed once again to update the firmware and make settings to the device.

In addition i would like to add that on Xbee S2 End Devices are forced to be using Cyclic Sleep (Sleep Mode 4)

Please read the following for more information.
https://code.google.com/p/xbee-api/wiki/ChoosingAnXBee

Last night i tried to set the sleep mode of an end device to 0 and it would not let me.


Logged

Pages: [1]   Go Up
Jump to: