Go Down

Topic: Atmega328 custom bootloader (Read 700 times) previous topic - next topic

RobertEagle

Sep 10, 2012, 01:33 pm Last Edit: Sep 10, 2012, 02:04 pm by RobertEagle Reason: 1
Hi,

I've been reading dozens of articles about loading a bootloader into an Arduino using another Arduino(in my case, the Duemilanove), and honestly I don't get it, it gives me continuous errors(like Error while burning bootloader).

The Arduino which I want to program is the ArduPilot Legacy. I want to put in it a custom bootloader, which I found it on the sparkfun website for wireless purposes. The problem is that I can't program it in no way. I've tried all the bootloaders in the menu, nothing worked.

This is the configuration I made:
-pin 13 goes to pin 13(to ArduPilot)
-pin 12 goes to pin 12(to ArduPilot)
-pin 11 goes to pin 11(to ArduPilot)
-pin RESET goes to pin 10(to ArduPIlot)
-and the 5V power supply.
-it has no other components (for instance a capacitor)
-the program which I have uploaded to the Duemilanove is the ArduinoISP found in the arduino folders.
-the programmers is selected as "Arduino as ISP"

Now, this is the reference website for the new bootloader which I want to burn.
-http://www.sparkfun.com/tutorials/122 and this is the zip file (www.sparkfun.com/tutorial/WirelessBootloader/Wireless_Bootloader_ATmega168.zip)

I'll say, I don't have a parallel programmer so instead I've chosen this way of bootloading. The next question is how do I bootload it using an Arduino as ISP?
I'll be glad to hear someone that knows how to do it, because I staying here and trying to get it work for some time.

Thank you in advance,
RobertEagle

NiñoScript

Did you disable the auto-reset in the Arduino that's acting as the programmer?

According to http://arduino.cc/playground/Main/DisablingAutoResetOnSerialConnection
you can put a 120? resistor between 5V and Reset.

I personally didn't have a resistor like that and didn't want to make one because I'm color blind, and that means I can't read colour coding and need to test each one…
So I just put a 10µF capacitor there, it worked really nice, as it won't let the reset pin go down from 5V.
It's dangerous though, as a lot of current could enter through that pin and burn something… but meh, being a daredevil is fun.

tim7

In addition to Ninoscript's comments, Pin 10 on the Duemilanove should be connected to Reset on the ArduPilot, not the other way around.  Are the grounds connected?

RobertEagle

I've done it at last.
And yes, I figured out then that I have to switch the pins.
It worked.

Thank you,
RobertEagle

NiñoScript

Good job, I didn't notice the wrong connection :)

Go Up