Go Down

Topic: Arduino + Processing (64bit) (Read 1 time) previous topic - next topic

Guglio

Ciao a tutti,
oggi stavo provando ad utilizzare la libreria "firmata" quando compilando arrivo al fatidico errore

Quote

processing.app.SketchException: serial does not run in 64-bit mode.
   at processing.mode.java.runner.Runner.<init>(Runner.java:104)
   at processing.mode.java.JavaMode.handleRun(JavaMode.java:162)
   at processing.mode.java.JavaEditor$19.run(JavaEditor.java:473)
   at java.lang.Thread.run(Thread.java:662)


Ho provato a scatricare l'installer di java 32bit e 64, installati tutti e due ma l'errore resta...
Qualche potente sa aiutarmi?
Altrimenti non ho idea di come far parlare sto benedetto pc (Winzoz 7, 64bit) con il piccolo arduino!
ArduMAP: La mappa degli utenti del Forum Arduino

lesto

non devi scaricare java a 32 bit, ma semmai processing a 32 bit! un'altra soluzione è sostituire le librerie (i jar e i native) della RXTX di processing con quelli di arduino a 64bit (che però mi pare di nascosto usi la 32bit)
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

Guglio

Era troppo facile! Io mi stavo già complicando la vita! Grazie mille!
ArduMAP: La mappa degli utenti del Forum Arduino

lesto

che soluzione hai usato? processing a 32 bit?
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

ciao, penso di avere lo stesso identico problema con processing, ma non riesco ad applicare la soluzione!
ho provato a scaricare la versione di processing a 32 e 64 bit (windows) e ad installarle rispettivamente, ma il problema riscontrato non muta.

in seguito ho provato a sostituire le libraries, ma nulla, stesso errore.

potreste aiutarmi?

pitusso

Ciao,
io uso processing su linux 64 bit senza problemi.
L'unica nota dolente è relativa a talune librerie (tipo OpenCV) che non son disponibili per 64 bit.
In alcuni casi si trova il modo, in altri no...

Adesso vedo se mi son segnato eventuali problemi e soluzioni..

non ti preoccupare, sono riuscito a risolvere il problema.
sbagliavo nell'installazione della versione di processing.

ciao e grazie.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy