Pages: [1]   Go Down
Author Topic: Arduino Driver - ATMega2560 - Windows 8 RTM  (Read 7987 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 1
Posts: 126
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Trying to get Arduino ATMega 2560 driver installed on Windows 8 RTM.

It shows as no driver installed.

If I point to Arduino\Drivers it says no driver found.

Any ideas?

Chris
Logged

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 19
Posts: 3114
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This might help - http://arduino.cc/forum/index.php/topic,94651.0.html
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 126
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks, but I am not getting a driver error - it says no driver found at all.

I have also enabled the Windows 8 Advanced Boot option about unsigned drivers.

But it is not finding a driver at all so it is not complaining about what it found!

Thanks

Chris
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 126
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Really hoping someone can give me another idea for a driver for AtMega 2560 on Windows 8 RTM

Chris
Logged

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 19
Posts: 3114
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It is a pre-release, unsupported platform.
Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What version of the Arduino IDE do you have?

If you browse to the Drivers folder, do you see the following driver .inf files?

Arduino Leonardo.inf
Arduino MEGA 2560 REV3.inf
Arduino MEGA 2560.inf
Arduino Mega ADK REV3.inf
Arduino Mega ADK.inf
Arduino Micro.inf
Arduino UNO REV3.inf
Arduino UNO.inf
Arduino USBSerial.inf

If so, make sure when installing the driver, you select the Drivers folder and NOT the "FTDI USB Drivers" folder.
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 126
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the tip - I right clicked on the Arduino MEGA 2560.inf and selected install and then it installed.

Funny how when I told Windows to go to the Arduino\Drivers folder it did not find anything?

But I am now away under Windows 8 so thank you for the advise.

ps: I have also enabled the unsigned driver option in Windows.

This method does not require new driver files or installation of a test signature.

1. Windows Key + R
2. Enter shutdown.exe /r /o /f /t 00
3. Click the "OK" button
4. System will restart to a "Choose an option" screen
5. Select "Troubleshoot" from "Choose an option" screen
6. Select "Advanced options" from "Troubleshoot" screen
7. Select "Windows Startup Settings" from "Advanced options" screen
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement"
11. Once the system starts go to Arduino/Drivers folder and right click on the Arduino device you have and select install.

I think you should be good to go then.
Logged

Pages: [1]   Go Up
Jump to: