Pages: 1 [2]   Go Down
Author Topic: 16x2 LCD shows only black boxes in the bottom line  (Read 6837 times)
0 Members and 1 Guest are viewing this topic.
New Delhi,India
Offline Offline
Newbie
*
Karma: 0
Posts: 23
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

nothing happened when i turned it over before...it was still the same.
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 26
Posts: 4118
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
nothing happened when i turned it over before...it was still the same.
No it was not the same, unless you have a very unusual display.

Don
« Last Edit: October 14, 2012, 08:58:35 am by floresta » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i know this topic is closed but many of will coming here with the same problem
i was facing this problem too and just find out why it was.
one thing is very clear that you are watching lcd up side down
as i was doing too. and second thing that led is not being communicated.
in my case i didn't conected the r/w to ground by connecting its working properly
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 26
Posts: 4118
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
in my case i didn't conected the r/w to ground by connecting its working properly

You obviously have looked at some old threads but you haven't gone back far enough.  The problem of not connecting the R/W line was quite prevalent several years ago but has only shown up one or twice in the past few years.  The connection is clearly shown in the diagram with the tutorial (http://arduino.cc/en/Tutorial/LiquidCrystal) and is also mentioned in the program comments.


Don
Logged

Pages: 1 [2]   Go Up
Jump to: