Go Down

Topic: How to call a simple webpage with WiShield 2.0 (Read 240 times) previous topic - next topic

siliconghost

I'm trying to figure out the easiest way to call a webpage using my WiShield 2.0. I've been poking around with the Web Client example code but can't seem to get it working. Note that examples to do this with the Ethernet shield are not of much use because the libraries are not compatible.

This is for a test project and all I want to do is call a site such as http://xxx.xxx.xxx.xxx/pagename.php?q=variabletext

I thought I might be able to use webclient_get() for this such as: webclient_get(server_ip, 80, texttopass); but that doesn't seem to work. When I debug I can see that "texttopass" correctly shows up as: "/pagename.php?q=texttopass"

I suspect I'm using webclient_get() incorrectly but it doesn't throw any errors during compile or debugging.

Any tips?

John

PaulS

Quote
Any tips?

One. Post your code. We have no idea which library you are using, so any help would be just guesswork, and it seems you've done enough guessing.

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview