Pages: 1 [2]   Go Down
Author Topic: Programming an ATtiny85 w/ Arduino 1.0  (Read 7769 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I  also got rid of that annoying warning: "avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85". By inserting dummy values in the avrdude.conf file (hardware/tools/avr/etc).

Insert after the signature declaration under the ATtiny85 section:

     signature        = 0x1e 0x93 0x0b; (this is already there)

     pagel            = 0xD8; (insert this)
     bs2              = 0xE2; (insert this)

Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 76
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Like ateller, I also had success with Arduino 0022 and the MIT/HLT library. I did get an error when loading the Bootloader, but if I ignore it I can still load the Blink example. I tried with some ATtiny85's that I haven't used yet just to be sure. Other details:
  • 119 ohms (from combined resistors) between 5V and RESET
  • 10uF capacitor between GND and reset
  • Mac OSX 10.6.8;/li]
Not sure if the capacitor s necessary since ateller had success without it. I also tried Arduino 1.0 with the other library ( http://code.google.com/p/arduino-tiny/ ), but still no luck there. It's totally worth keeping 2 versions around to make this possible. If I can help debug the 1.0 version, I'd be happy to provide more info or try other things.

(w00t!)
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 76
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Well, I'm not out of the woods yet. It looks like I haven't been able to change the clock frequency or something. Instead of running at 8MHz, it seems to be running at 1MHz, but still running the program as if it was running at 8MHz. For example, delay(1000) takes 8 seconds, instead of 1.

Like I said, there is an error when I try to Burn the Bootloader in Arduino-0022. Here's the verbose output of that error: http://pastebin.com/7D9GYimW

Incidentally, if I select "ATtiny85 at 1MHz (internal oscillator; BOD disabled)", then delay(1000) takes 1 second, as it should. I would try burning the 16MHz bootloader with an external oscillator, but I'm not sure how to connect the oscillator to the ATtiny.

Programming ATtiny's at 1MHz is cool, but it would be nice to have a faster clock for serial support, etc. If I can just get that clock frequency changed, I'm good to go.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 197
Posts: 12739
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1274820597/99#99
http://code.google.com/p/arduino/issues/detail?id=808
http://arduino.cc/forum/index.php/topic,89978.msg675775.html#msg675775
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 76
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Those changes are made to avrdude.conf, or dealing with WinAVR. It seems like these are specific to the Windows platform, correct? Is there a similar file on Mac OS X systems to edit?
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 197
Posts: 12739
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Is there a similar file on Mac OS X systems to edit?

Yes.  No matter what the operating system, avrdude is always driven by its configuration file (avrdude.conf).
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 76
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah! found it. It's working beautifully now, thank you!
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 197
Posts: 12739
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


You are welcome.  I'm glad you have it working.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have tried with the Arduino Uno and with the Mega and they work fine with the 10 uF capacitor. Even connecting them to the ICSP (except for the Reset that stays in pin 10 for the Uno and 53 on the Mega) they upload the sketch, no problem.
The issue comes with the Arduino Nano. I have tried with the resistor between 5v and reset and I always get the same error. With and without resistor or capacitor there is no way to upload anything. Using the ICSP happens the same thing as expected:

avrdude: stk500_recv(): programmer is not responding

Any help? thanks.
Logged

Aura Communications: Arduino projects and electronic shop

Denmark
Offline Offline
Edison Member
*
Karma: 35
Posts: 1051
Happy Hobbyist
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I have no problem using the Nano as programmer.
I use the usual 10uF capacitor from reset to ground.
Maybe it is because I use Coding Badly's TinyISP, you could try that.
Logged

Pages: 1 [2]   Go Up
Jump to: