Pages: [1]   Go Down
Author Topic: avrdude: usbdev_open(): did not find any USB device "usb"  (Read 4325 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 134
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i am trying to use a 10 uf capacitor and arduino uno with attiny 84 to program the tiny with a blink example but i get the error "avrdude: usbdev_open(): did not find any USB device "usb"" and I am not sure what to do...When I tried to program the tiny with a USB ISP AVR it gave me the same error so I am not sure what went wrong here...I soldered the tiny to a proto board so hopefully i didnt burn it if thats the issue...
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 179
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found the best way to stop impestive rebooting due to IDE messing with DTR line was to cut the link provided on the UNO.

I use a knife to short the broken link when I want to use 'dude, or just try to judge the right moment to release the reset button so that the bootloader is listening when the IDE tries to send the program data via 'dude.

The latter is a bit of a knack since you only have 0.5s window to release the button, but you get the hang of it.

I think I tried the 10uF trick but did not find it worked.
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 134
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i get the same error when i use a usb ISP....
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 134
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i dont think avr dude is an issue because when i try to program uno with the capacitor still in i get the error

 avrdude: stk500_getsync(): not in sync: resp=0x00


which is correct since i shouldnt be able to program uno with the capacitor in there so then why isnt it properly programming the tiny? im trying to program the attiny84




NOTE: I forgot to change from tools to programmer as arduino ISP so once I did that the previous error went away but at the end of the upload i got this error when trying to program the tiny:

avrdude: stk500_getsync(): not in sync: resp=0x00
« Last Edit: September 19, 2012, 01:56:20 pm by twirap » Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 134
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

new error:

avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny84
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny84


the code seems to work now while giving that error in uploading process..

not sure why i get those errors but solution to make it work was simply once you upload the code to arduino to make it an ISP, plug the usb of arduino out and replug it in then upload code.
« Last Edit: September 19, 2012, 02:33:23 pm by twirap » Logged

Pages: [1]   Go Up
Jump to: